RT 2.4.4-alpha Released


#1

Just discovered RT 2.4.4-alpha on GitHub in case anyone is interested.

Bruce


#2

There be dragons…


#3

Indeed! :slight_smile:


#4

First look at 2.4.4-alpha on a Win 10 laptop…

  • The distracting jump in screen size is still there. Jumps constantly because of the 2-decimal point resolution of IR Drum Temp causing a slider bar to appear/disappear on the right side of the window. Please reduce the resolution of that displayed number. Knowing IR Drum Temp to 1/100 of a degree is pointless.
  • Now a new ghost temp line has appeared on the screen. If the color codes are to be believed it’s Exhaust Temp but I doubt that. Very hard to see as it’s light-grey:

I notice the R.W screenshot capture trims the right edge of the image so the slider I wanted to show isn’t visible. It was there when I previewed the screenshot.

Bruce


#5

So much for bleeding edge software.

After updating to f/w 523 (yes, cycled the power; took three times to see S/N), I tried to get a roast started. RT was working with the usual display as it preheated. I was fixating on the new lt-grey temp line (???) and went back to an earlier s/w release to see if it and the &&^%$$ jittery display would stabilize. Somewhere in all the reinstalls RT started coming up as a blank screen.

So much water has run under the bridge that I’m not able to reconstruct what happened in sequence but at this point I have a blank screen in RT. It doesn’t matter what version I install, the screen is blank with only the menu bar showing:

Cycling power, disconnecting the USB cable, installing/starting/restarting any version of RT, rebooting the computer all leave the same result- blank screen. I would go back to the stable release of f/w (515?) but selecting Update Firmware doesn’t alter the blank screen… no response to Update Firmware (the pop-up window that manages f/w update nevers opens). Selecting About in the About menu item gives the right s/w version info; selecting Help and then Learn More pops up the R.W page, Other menu items don’t respond.

Under Tools I clicked Force Update Drivers which seemed to go thru the proper steps for installing. Device Manager sees the drivers and says they’re working. Still RT is blank.

As a last ditch I did the reset of the bootloader, but of course that doesn’t change much if RT isn’t working properly. I believe the Bullet would roast coffee, but RT is not operating.

Any thoughts?

Bruce


#6

If you actually need to roast, I’d just do it manually from the Control Panel. I’d refrain from doing anything else to your PC right now to give Jacob time to respond and suggest the best route to restoring RoasTime.

There should be a “Bleeding Edge Badge” for Bullet Users that want to experiment and tread the unknown! :nerd_face:

image

Being an old Mainframe Field Engineer, there was always one principle that we typically followed with firmware and software changes. Make one change at a time. Allow each change sufficient time to be tested/flushed for any problems to surface before adding more changes. Otherwise, things can get so muddled that it becomes difficult to recover. :wink:


#7

You’re right of course. “Just like last time…” is a myth.

I’m fairly certain the registry is corrupted, but I don’t see editing tools with Win 10. So I’ll have to contemplate my sins while awaiting inspiration! :wink:

Bruce


#8

I suspect you might need to follow those clean install steps that have been here before deleting Aillio and RoasTime folders from your Windows profile…


#9

I’d thought about suggesting the “clean/wipe” stuff and then figured if the problem is gone and Jacob engages for help, there may not be any data to share with him for diagnosis. On the other hand, “ability to roast” is my prime-directive that supersedes all desire to test new stuff.

So, that post (from Jacob) on which folders to delete is in the thread (below). I can tell you that it will delete all of your local roast data (if that matters).
Clean-wipe of Aillio/RoasTime data


#10

That link to the post from Jacob re:which User folders to delete did the trick. I was able to install without issue. Had to log-in with RoasTime for the first time in months… nothing like a memory test to remind me how old I’m getting!

Thankfully the roasts are all there except a few I deleted from conditioning the drum. I didn’t do anything in the way of setup, so RT must be uploading them to Roast.World by default.

Thank you for the Get-Out-of-Jail card. In the mean time I had lunch and a nap and woke up grinning from ear to ear as I heard the sound of monsoon rain outside. Turned out to be a good day after all! :slight_smile:

Bruce


#11

Good stuff…glad you are back using RT. Roasting with software tools becomes something you like to do even though many of us could do it the old fashioned way. That wipe process of those folders saved my bacon back when I was first using the Bullet and I’m glad Jacob shared it. :vulcan_salute:


#12

Yes, if you are using the online uploads of your roasts, that can be a benefit in this case. Back when I deleted those 2 folders, I was only roasting in local mode. So, in that scenario, all my local roast history data was purged. It was not a problem for me since most of those early days roasts were tests and seasoning.


#13

re: conditioning roasts… I deleted them because they were so far away from anything that might have worked I was too embarassed to keep the evidence! :rofl:


#14

I discovered the source of the lt-grey ‘ghost’ line on the chart… they’ve swapped the default colors for RoR and Exhaust Temp. I had to go thru the default settings in RT (light background, Fahrenheit) and stumbled on the new color selections. You can dial in essentially any color you want for each of the 4 plotted parameters (I like it!). Unfortunately they misidentified RoR vs. Exhaust Temp.

Bruce


#15

Glad you got it figured out. I have messaged Matthew about the issues.


#16

Delighted to hear that! Thank you Jacob…

Bruce