RT 2.5.3-alpha Released


#1

Just found RT 2.5.3-alpha on GitHub. Sadly Messages contains no Release Notes so I can’t tell what it addresses.

Bruce


#2

Well what are you waiting for! We’re waiting for you to find out. :grin:


#3

:smile: Pretty soon. Having monsoon rains at the moment and when you live in AZ you never complain about getting some rain!

Bruce


#4

A modified RT 2.5.3-alpha was just released on GitHub.

Looking at Win 10 Properties -> Details it appears this is build 185 (that’s my interpretation, not anything from Aillio; I’ve labeled it RT 2.5.3.185-alpha). Haven’t even tried the first 2.5.3-alpha yet- I better get my butt in gear! :slight_smile:

Edit: I see that Help Desk is now active in Messages of RT 2.5.3-alpha. No update to Release Notes yet, so no idea what else to look for.

Bruce


#5

Wow! They just keep coming.

Another update to RT 2.5.3-alpha on GitHub, this one (in my vernacular) is build 189. Thank you Matt!

Nothing obvious beyond what I noted already. Planning to roast tomorrow so I’ll get a chance to actually try this version of RT instead of just updating s/w!

Bruce


#6

Roasted today with what I called RT 2.5.3-alpha Build 189. I wasn’t able to identify anything as having changed from the first release of 2.5.3-alpha.

I did have an issue with updating f/w after roasting. The Bullet was in Shutdown mod (not Off as I normally would) with fans blasting when I finally thought to check for a f/w change. I was at 523 and found 533, so as a final step before putting things away I did the update. Didn’t go well, but d/l’ing 3 times I finally felt I had a proper d/l.

Screenshot%20(24)

I haven’t seen this message before (added in the update?) and the commend string doesn’t look familiar in a Win 10 context even from a Command Line prompt. Worse still, it’s like an unwanted tattoo… it just won’t go away no matter how often I cycle power on the Bullet, restart RT, or fuss with the USB port. Look familiar to anyone? If all else fails I’ll re-install RT. (I’ve started a Help ticket.)

Another oddity which may be nothing more than not paying attention in the past. I did several back-to-back roasts, but for some reason when I started Pre-heat for the last roast I noticed the exhaust fan wasn’t operating. The drum was at ~44X°F and I thought surely the exhaust fan should be turning at that temp as the drum has to cool to 410°F (the Pre-heat setting). For the life of me I can’t recall if I’ve ever noticed the Exhaust Fan running under that condition. Anyone payed attention to that?

I also noticed that both FC and SC are starting about 10F° sooner than I expect, i.e. FC is starting about 380°F instead of about 390°F. I assume it may be a dirty IBTS lens so I did some out-of-season Spring cleaning after everything cooled. Later, when I checked roast data, I saw that the same thing happened a week ago. At that time I’d blamed it on new beans I wasn’t familiar with, but that excuse doesn’t fly this week. Looks like I’ve got about 6 or more pounds of coffee roasted darker than I wanted. Especially the espresso… the Admiral is not going to be happy! :frowning:

Bruce


#7

Bruce, you live too close to the edge. :slightly_smiling_face:

I’m still at 515/2.5.0 and not having those exact problems…but I have some quirky fan issues such as the exhaust fan seeming to stop before the cooldown was completed. I quickly toggled the PRS button to get back to cooling and the fan ran properly.

Also, after I press the F1 to do a back to back, I can’t get the F2 button to toggle to C when I’m ready to slow the cooling tray fan, although I can still use the fan speed button to lower the cooling tray speed. I thought upgrading firmware to 515 would fix, but didn’t.

I’ve seen no change to FC temp, generally around 200C, and I don’t roast into SC. Was your environment temp and humidity normal?

I hope you get that error message removed.


#8

I’ve noticed that cooling fan quirk and reported it. If you don’t switch the display to show cooling fan setting before pressing F1 to enter back to back mode you can still change the fan speed but you’re blind…


#9

I noticed the issue with trying to use F2 when going to back-to-back roasts.

Unfortunately hadn’t planned on going to SC either, at least not with these beans. And the espresso beans (which do go to SC) looked like French roast instead of Vienna. My fault for not paying attention the previous session. Lots of crud when I cleaned… dark oily film everywhere, so it was time. The IBTS didn’t look dirty, but it got an alcohol cleaning anyway. I’ll have to see how it goes next time.

Bruce


#10

Great. I was reluctant to open a ticket cuz I wasn’t sure if it was a f/w behavior issue or if I had a local h/w problem.

Bruce


#11

I did a single roast today to make sure everything is ok post-cleaning. The roast went well and the temp offset is gone.

The f/w update saga continued before I could do the test roast. Had to d/l the f/w a 4th time then cycle the power on the order of 4 times before I got the f/w change to be recognized by RT. I finally had to exit RT and restart it, then the new f/w ID (533) was recognized. I don’t believe I’ve had an issue like this with f/w update before, certainly not requiring that I exit RT for the change to be recognized.

Btw, the odd message went away after the 4th f/w update and after restarting RT.

Whatever, that’s all just whining cuz it looks like I’m back to familiar territory.

Bruce


#12

I came here to post about this same dialog. I’m getting it too.


#13

You’re getting the comm error message too? Must be part of the changes to RT. I’m reasonably sure in my case it had to do with corrupted d/l of f/w, but… ??

Bruce


#14

Do you fixed it by simply updating the firmware 4 times? Strange.


#15

The 4th time I still had the message and had to restart RT to get rid of it.

I assume it took 4 times because the d/l was corrupted the first 3 times. Wasn’t acting right after each d/l. The 4th d/l was the next day.

I think I set it up for failure cuz the roaster was in Shutdown mode when I started, not Off mode.

Bruce


#16

I just found 3 new alpha/beta/internal releases on GitHub. One of them (??) is aimed at issues with the USB comm that they suspect is behind the problems some of us had updating f/w.

Edit: Found-

  • RT 2.5.3-alpha Build 191 (was Build 189)
  • RT 2.5.4-alpha Build 193
  • RT 0.0.0-internal Build 194

No way to know what changed in 2.5.4 vs 2.5.3 as there are no release notes for 2.5.4. However 2.5.3 does have release notes:
1- Added Help Desk -> it’s working
2- Fixed line coloring -> it’s fixed
3- Fixed internal logging issues -> dunno (is this Info/Log?)
4- Added exit buttons for modals (pop-ups) -> dunno yet
5- Fixed issue with max pre-heat setting being too low/high -> dunno… wasn’t an issue for me

0.0.0-internal looks like something not intended for the likes of users! Probably included in Releases in error.

Bruce