RT 2.5.5-stable missing roasts


#1

I upgraded to 2.5.5-stable about a week ago - Win32-x64, Dec 2, 2019. On Jan 29 I roasted 3 batches. Today I checked both RT on the same laptop and RW, and find that:

  1. first roast is there as expected
  2. 2nd roast is there with missing data - description, etc. but plot is there
  3. 3rd roast is no where to be found

Given this and my problems with the chart going all wonky when I tried to change the settings, “2.5.5-Stable” doesn’t seem so stable to me.


#2

Do the roasts display ok in RT? If so, try re-loading My Roasts page in R.W with RT running and connected. I’ve had occasions of missing roasts because R.W hadn’t finished loading via the internet (but I’ve not had corrupted roasts).

Bruce


#3

Bruce,
Thanks for the suggestion. Unfortunately no, the 3rd roast from that day is just plain gone. I have screen caps but that’s all. First time this has ever happened. I am going to go back to RT 2.5.0. I see that they are working on a new 3.0 release, maybe in a few months I’ll give that a try. :slight_smile:
Will


#4

Bruce, you mentioned several iterations of 2.5.5 - once you install it, can you tell which version you have from RT?

I’ve been running 2.5.5, not an early version (December 13) and have not had problems in the 21 roasts since. Upgraded f/w to 523 (on January 14).

Wm1, the only roast I ever “lost” was when running a Recipe for the first time (after it was added into 2.5.0) and got to the end…a message box popped up and I clicked the “X” box in the top right corned rather than the message Button…RT and the Bullet panel locked up and I had to unplug. Aillio couldn’t reproduce this and I haven’t had it happen again (but have only used recipes twice since).


#5

re: RT versions… this is way too much info, but it explains how I keep track of all the s/w releases from Aillio. I use Win 10 so I can’t help with the other s/w packages, but in Windows-

  • On GitHub, I pay attention to “commits”; if the number of commits increments upward, I download the release to a location where I keep all the Aillio RT files. I edit the file name to give it a unique temporary identity without losing the basic ID usually by inserting “.xxx” after the basic file ID.
  • Right-click the file name and click Properties.
  • Choose the Details tab and note the Production Release number. I use this info in my naming convention for the file just downloaded. From what I think I understand,
    – if the Production Release ID is new (increased), there is possibly a change to the s/w that affects behavior;
    – if the Production Release is the same, there is probably no change that a user will recognize.

When RT is being worked on there can be a lot of changes. I worked out a way to keep track of changes to RT by modifying the file name slightly to add the Production Release number and the number of Commits. For example…

  • the first release of RT for the current ‘-stable’ release was on 2 Dec 2019 and was named “RoasTime.Setup.2.5.5-stable.exe”. To keep track of this release I created a unique ID of “RoasTime.Setup.2.5.5.226-stable(05).exe” and installed the new version.
    – “.226” refers to the Production Release number and
    – “(05)” refers to the number of commits.
  • a few days later on 6 Dec 2019 the number of “commits” changed to "8"and I d/l’ed the new file;
  • Properties -> Details -> Production Release showed a change, so I saved the file as “RoasTime.Setup.2.5.5.227-stable(08)” where “.227” is the new Production Release and (08) is the new number of “commits”.
  • Since 6 Dec there have been 5 additional changes to this same root-ID of RT (4 Jan, 6 Jan, 9 Jan, 14 Jan & 16 Jan). That’s seven releases in all to RT 2.5.5-stable though I think only the second had changes that may have affected behavior. I saved them all with a unique file name for each that includes the Production Release number (unchanged for the last 5) and the number of commits (each is different). I also installed each to be sure they didn’t crash (they don’t).

I also keep track of (and d/l) -alpha, -beta and -internal releases but none of these have changed since Dec 2019. My preference is the -beta release, but the current -alpha, -beta and -internal have a problem when viewing older charts that causes the displayed temperatures to switch from °F to °C after the first chart even though the chart labeling says °F. Since I keep an archive of all the d/l’s I can revert back to something that works if I have to… which is how I happen to be using the current -stable release.

As I said, way too much info (mea culpa!). But we have a development environment and sometimes a release will have issues so I have to be able to back-track to keep roasting. In truth this is a level of detail fussiness I avoid, but I swore I wouldn’t get caught again when I crashed hard back in Sep 2019.

Bruce


#6

Bruce,
I’m glad you like to keep track of all this. Frankly I think this is crazy (in lieu of a less polite word).

I get that there is beta software and I’m happy for the people that want to play in that sandbox.

This is exactly what I do NOT want to do. I am not a developer working on this (believe me I’ve done enough of that already - and you don’t want to know), and I did not sign up for “Beta”. If a software release is marked as “Stable” I expect it to be reasonably well tested. We all paid a lot of money for our Bullet’s. I think we deserve a little better reliability in the software. And please, don’t tell me about how hard this is or how few people are working on it - that’s Aillio’s problem, not mine. Besides, didn’t they tell us recently how they are growing and hiring lots of new people? :slight_smile:

I’m going back to 2.5.0, which actually was “stable”, at least in my experience.

Will


#7

Quite a system. I’ll be happy to continue relying on you for notifications of release updates, as long as you are willing.

While running RT, I could only find that it is 2.5.5., no other date or version info, but my Bullet is running fine, so no need to make any changes for now.


#8

Ok… happy to share what I find! :slight_smile:

The info I look for is associated with the d/l’ed file only. Nothing in RT will tell you.

Bruce


#9

Bruce,
If you want to post software updates and status (great idea!), please start a new thread for it.
Thanks,
Will


#10

I wish Aillio would use a unique version number for each release. I have 3 apps called “RoastTime 2.5.5”, only one of them works.


#11

For that matter, how about official “release” information? As it is now, there is only what is on Github. The thread that used to list releases appears to be closed.


#12

Are you saying that https://downloads.aillio.com/ is not official release information? It states what the most current stable release is.


#13

I was somehow not aware of that page, thanks.


#14

Do I want to go in to all the software?
I like roasting coffee by Sound and Sight.


#15

Are you saying that https://downloads.aillio.com/ is not official release information? It states what the most current stable release is.

There is very little information on that page. Knowing that 2.5.5 is “the latest” doesn’t mean anything because there are several versions labeled 2.5.5.

I appreciate the bug fixes, don’t get me wrong! I’m using the 2.5.5 from Jan 6, it works. The 2.5.5 from December does not work for me.

Release notes for 2.5.5:

{ 
  "version": "2.5.5-stable",
  "notes": [
    "Everything from 2.5.5-beta.",
    "MacOS Catalina capability"
  ]
},{ 
  "version": "2.5.5-beta",
  "notes": [
    "Logging fixes and improvements."
  ]
}

#16

Damon you say “There is very little information on that page. Knowing that 2.5.5 is “the latest” doesn’t mean anything because there are several versions labeled 2.5.5.”.

The aillio download site will give you options for both a stable version and a beta version. One can decide whether he/she wants to roll the dice and get the latest and (maybe) the greatest, or whether he/she she is more interested in roasting coffee than experimentation.

The stable version link is clearly highlighted and labelled as such. ​Download Latest Stable Version 32-Bit

Below that it offers the beta version: Get the beta version /

If you feel I am missing something, please elucidate.


#17

If you feel I am missing something, please elucidate.

Sure, maybe a pic can clarify. I downloaded 2.5.5 stable in December, got one thing. Downloaded 2.5.5-stable again in January and got another. The January one works for me, the December one has a display bug. The files are different sizes, same version number. The release notes are the same for both.


#18

Thanks …that is indeed weird. I just assumed the one indicated as ‘stable’ was just that. I guess the fact that I have never had a problem with any upgrade led me to assume my belief was correct. Appreciate the heads up.