RT and MacOS Big Sur / M1 Macs

An observation and a question:

  1. RoastTime 3.0.76 and 3.0.79 seem to be working just fine on MacOS Big Sur (11.0.1). I can find no issues that I would not have found on on Catalina. This is on a 13" 2017 MacBook Pro.

  2. My aforementioned MBP has a permanently dead battery, and I need to send it in for work. During that time, I will have my brand new shiny shiny M1 MacBook Air. Has anyone tested RT on an M1 (Apple Silicon) machine? I would assume it would run in Rosetta, but are there any issues? Or, am I the sacrificial lamb? :fearful:

1 Like

I’m also very interested in this. I would love to replace my 2015 12” MacBook with an M1 MacBook Air, but am hesitant to upgrade to Big Sur.

I am currently running Roast Time on a 2020 MacBook Air running Big Sur. I have not encountered any problems so far.

1 Like

Big Sur isn’t an issue, you can run that on your current MacBook with no problems. Roastime works fine on it, I’ve done about 20 roasts with it.

The M1 should be fine, providing that Roastime runs successfully in Rosetta. It won’t run in Universal mode, since it hasn’t been compiled for M1 yet. I think.

Let me clarify a bit: you should be able to use Roastime on your current MacBook, running Big Sur, if your current MacBook can run Big Sur. I don’t know if the 2015 12” is one of those or not. That should be solved with a quick check on the Apple site.

I ran my first couple roasts today with an M1 Mac driving RT. No issues at all — ran just like on my previous laptop.

2 Likes

That’s good to hear. I’ve got my new M1 in, but I haven’t installed RT on it yet.

Any new experiences meanwhile?
I installed my new M1 Macbook with latest version of RT running on Rosetta, but don‘t get it connected to the roaster using original Apple USB adapter. With my former 2010 Intel Macbook which is broken it had been working plug and play. Did anybody use it successfully?
@jesserichmond Did you just plug it in and it worked or did you habe to configure something?

I didn’t have to do anything special. I use an Amazon Basics USB-C adapter, but I just plug it in and it works.

1 Like

I’ve had no problems, it was plug and play using my Apple USB-C adapter.

1 Like

I played a little bit around with unplugging and plugging in USB again and now it works.
Still have issue with login in with my RoasTime account, if that‘s solved I can start roasting again hopefully…

I’m having what I think is an M1 issue that’s “showing itself” as an account issue.

This was resolved by upgrading to RoastTime v3. I didn’t realize I had downloaded an old version. Everything else seems to be fine, so +1 for the M1.

1 Like

Glad you got it worked out.

Roastime is still running stable, but a little bit too “stable” unfortunately. When I close the app some roastime processes keep alive and hindering my Macbook to shut down. After having killed the processes via terminal shutdown is possible, but after next Roastime start I have the same issue again.
Any idea how to quit Roastime completely?

Nobody any idea how to solve?
It’s annoying to searh for all the processes and kill them manually to quit the app…

Try a two-step shutdown: first use the red X in the upper left to close the main window. Then in the top bar Roastime > Quit Roastime. This works for me on M1.

I’m having a different issue. I just upgraded to a new M1 Pro and installed 3.4.1. When I launch the program the entire Roastime window is solid white. I’ve rebooted the os and reinstalled and still get the same result. Would an earlier version be worth a try?

FWIW, I just updated to Monterey 12.4.

Mark

You need to uninstall and then remove all the files of RT manually in the app folder. After this install again.

How do you uninstall? I typically delete an application by selecting it within the Application folder and moving it to the trash. I deleted the Roastime app within the Application folder and reinstalled but get the same result.