[SOLVED: Use Celsius] RoasTime Stable 2.5.5 & Recipe Triggers


#1

Second day with my Bullet – one of those noobs who managed to squeeze in a purchase at Sweet Maria’s – and having a helluva time trying to figure out how to get a recipe trigger to fire. First day was mostly spent running some cheap beans through to season the drum, and did some half-assed attempts while doing that to create & run a recipe, with no success. Today I sat down and tried to figure it out in earnest, but still a bit lost.

The best I can do so far with a recipe is get the Bullet to preheat to the proper temp, and set the power, drum, and fan speed at charge time. Any triggers I’ve tried to set after that fail to fire. Managed to get 4 kilos of Java run through it for all the neighbors who put up with the smoke yesterday while seasoning, but NONE of those batches ever made it to even the second step of the recipe I was fiddling with, beyond the initial charge.

I suspect I’m doing something stupid with the time half of the triggers, but I have no idea what. After 4 kilos, those time and temp values are pretty well dialed in (checked the roast curves on each previous batch every time I reworked it, dialing in those variables).

Anyone have pointers for getting triggers to fire when roasting from a recipe?


#2

Hey Jeremy -

Congratulations on winning the SM lottery!

For the temperature triggers, I interpret the time value like “time is at least xxx”. The idea is that you don’t want the trigger to fire at the very beginning of the roast, when the temperature is hot and falling because you just added beans. So if you set a time value of say 2:00 you’ll get past the first part of the roast and into the ascending portion of the curve.

I usually preheat until ready to charge, then switch screens, pick a recipe and activate it, switch back, and add the beans. You should see a notice on the left sidebar something like “Recipe Mode” (don’t remember the exact text) verifying that your recipe is running.

Hope that helps! - Brad


#3

Yeah, with the Sweet Maria’s sale, I had alarms set on my watch, my phone, and all the Google Home units in my house, so I was able to hit that Buy It Now button as soon as it was available…

Anyway, if you take a look at that recipe image, I have the first trigger set for 2:15 – which is two seconds before my IR bean temp hit 250F. So, at 2:17 into the roast, temp hits 250F, and… nothing. I wait another 5 seconds to see if there’s maybe a delay, but nothing still. At that point, I just manually change my roast parameters.

I started the roast from the recipe page, hitting “Start Roast” up there in the right hand corner. It switches over to the current roast screen and waits for me to hit the preheat button, and takes off from there. It does show “recipe mode” there on the current roast screen while I’m in the middle of it, but none of the triggers fire.


#4

I set the time values at around 2:00 for all temperature triggers. Just a guess, but maybe your time values are too close to the actual time the target temperature is reached?


#5

My first few attempts went that way: set trigger times (along with the appropriate temperature values) to 1, 2, 3, 4 minutes and up, assuming, like you, that the time settings just meant “at least this much time must have passed since the start of the roast.” It was when that produced no results when playing back the recipe that I tried to dial in the times closer to the actual times that those temperatures were reached, but at least a few seconds prior, so I’d hit the temps at at least this time frame.

And just to be perfectly clear: this is not an issue of the PC losing it’s USB connection to the roaster, or of the software locking up or crashing, or of the roaster itself becoming unresponsive to user input. I’m able to control the roast parameters (power, fan, drum) from either the software or the control panel just fine – it’s simply that the recipe triggers seem to be ignored.

This happens on two different Windows 10 PCs, running the latest Stable 2.5.5 RoasTime software. Given the state of development with the software, I’m starting to wonder if this function just isn’t finished in stable, and maybe I should try beta or alpha…


#6

I’ve always ignore the ‘And Time’ with the 00 left there. And I have no problem running the recipe.


#7

Yep, @fred0823, the first few times I tried using the recipe function that’s how I tried to do it – just ignoring the “time” portion, leaving the zeroes where they were. My temperature triggers didn’t fire.

Today I tried again, with 1lb batches. First try, using the “IR Temp” Bean Temp trigger to change power & fan settings, again leaving the “And Time” portion of the trigger at 0m 0s. No triggers fired. Second try, using the “Bean Probe” Bean Temp trigger (after correlating those figures with the IBTS figures in previous roast profiles) to set power & fan – again no triggers fired. Third time, tried selecting a previous roast profile and selecting the “Create Recipe” option, inserting the events from the previous roast as triggers in the recipe – running that recipe, once again, no triggers fire, and I had to just make my changes in the software manually.

Can any of you who have recipes that actually work as expected give me a screenshot – or just a text list of trigger settings and actions – that I can try to duplicate? And are y’all running beta or alpha versions of RoasTime? Screenshot here of the version details of the software I’m running:

I have noticed that there seems to be some confusion in the UI about whether I’m using Fahrenheit, like a normal human person, or Celsius, like a godless communist (joking of course). I suppose I could try switching my settings back to the default Celsius and seeing if that helps.


#8

Very interesting…the only thing I can think of which is different than mine, or I am not so clear the way you start a recipe running…
Here is my experience:

  1. Select one of the recipe you are planning to go
  2. Click ‘start roast’ button on up-right corner…
    (You should hear bullet saying ‘preheating’

If not, then it is a hint that you are not in the recipe mode. And one of the reason maybe because the bullet is not in the right mode when you click ‘start roast’

I use a lot of back to back roasting by pressing the f1 during the cooling stage and it works all the time.

Or when bullet is in off mode, try running the recipe by pressing the start roast and see if that solve the issue.


#9

There was a time when recipes only seemed to work in Celsius trigger temp…try that ?


#10

Appears I’ve figured out what I gotta do…

Powered up the Bullet, using changed from Fahrenheit to Celsius on the panel; brought up RoasTime, changed my roast settings from Fahrenheit to Celsius, restarted the app, and built a new recipe using IR temp triggers in Celsius (0:00 for time all the way through), and ran a 350g batch from the recipe, and there it is: all my triggers fired.

Power cycled the Bullet, changed to Fahrenheit on the control panel; changed to Fahrenheit in my app settings, restarted the app, rebuilt the same recipe with Fahrenheit temps, ran another 350g batch, and nothing…

Back to Celsius again, and I’m off to the races.

So, looks like I have to use these godless communist temperature settings after all.

Thanks all who chimed in!


#11

You can open a bug report here: https://github.com/roastworld/roast-time/issues