Uh oh. Firmware update failed [solved]


#21

I have had two MacBooks work great and one work poorly with my Bullet. One of the working macs has Mojave, the other El Capitan. The mac that doesn’t work didn’t work with either High Sierra or Mojave.

The main guess I have remaining is that I have installed custom USB serial port drivers for a number of microcontrollers on the machine that is failing, so I’m wondering if the Bullet’s new software is somehow conflicting with one of those drivers.

I recommend trying another computer, and in the meantime, I’m going to try to track down how to diagnose USB serial driver conflicts.


#22

Great, thanks!


#23

I have exactly the same problem as BlackStripeCoffee. Would. Be interested in any solution.


#24

My latest experiment was manually remove my USB drivers (I had two of them) and also to boot my Mac in “safe mode” (hold the shift key down while booting). This should disable non-Apple drivers. I verified that I was indeed in safe mode, but when I connected my roaster to the machine and ran Roast.Time, I still saw fairly regular very-brief USB disconnections. (The screen flashes to “your Bullet is not connected”, then resumes the session). I believe that in my case, these disconnections are what was causing the firmware update attempts to fail.

This seems like a hardware issue but I haven’t had any unusual problems with USB on this machine before. Hmmm.


#25

Does this only happen when initially plugging in? Or does it continue to do it while it’s been connected for a while? The reason I ask is because in some cases, the software is unable to properly “release” the USB device (for eg, unplugging before it can release) from the last session. In this scenario, the software may receive an error that the device is still “claimed” and attempt to rectify the issue which may cause the flickering “on, off, on” that you are seeing. This should only happen when plugging in for a brief few seconds though, not at any point after that.


#26

It happens throughout - at random intervals, though generally about once every four minutes or so. Definitely for as long as it’s plugged in (more than half an hour or so).


#27

Would you mind updating to the 2.0.7 debug version and opt in to send us data? This should give me a good idea of whats happening for you.


#28

Done. Email me at username at gmail if you need more details (or a movie of the app during the 2 minute run I just did).


#29

Has anyone rectified this issue? I just installed the new IBTS so am forced to update my firmware from the current 444. Unfortunately it’s still getting stuck at 0%. Tried numerous time, several different USB cables. Using the same Microsoft laptop that I’ve been using from the beginning…2 years ago. Please help!


IBTS installed - stuck at firmware 448 - updating stays at 0 %
#30

I finally updated to 448 by changing back to roastime version 1.
And stayed on roasttime version 1. I am afraid firmware updating in version 2… might still be impossible. Hope they will solve this bug eventually.


IBTS installed - stuck at firmware 448 - updating stays at 0 %
#31

Were you on mac? My RoastTime updated to 2.0.9 and I had to rollback to 208b in order to update firmware (209 wont connect to roaster because of USB issue)


#32

I tried again with a new computer (MAC this time) and its still getting stuck at 0%. What else do I try? I desperately need to get roasting again!

So it looks like I finally figured out how to update the firmware. After it freezes at 0%, shut down RoastTime and restart the computer (don’t disconnect the USB or power to the roaster - keep it running). Once the computer has restarted, reopen RoastTime and try updating again. Finally! Hopefully this works for everyone else having issues updating the firmware.


#33

Another comment on this update. I found on a Windows PC (Win10) that worked fine on 448, I had to FORCE UPDATE DRIVERS from the Tools menu. This seemed to work for me. I disconnected from Bullet while doing this update. Powered Bullet off/on. Then tried the 475 Update again. It worked.


#34

Yah of course… I’m looking to sell my Bullet and in good faith I tried to run a firmware update and I’m not able to do it (was frozen at 0%). What has been the best course of action for people running into this? Windows? Mac? I’ve tried on Mac. Have someone coming to check it out in a couple of days. :frowning:


#35

running the update from the older Mac roast time seems to have worked. Thank goodness!


IBTS installed - stuck at firmware 448 - updating stays at 0 %