Uh oh. Firmware update failed [solved]


#1

I just gave the new macOS Roast.Time beta 2.0 a try. I was able to roast fine, but the software kept reporting loss of USB connection, but then flashing back to connected. I tried multiple cables and USB ports on my computer.

I thought maybe updating my firmware could help, so I clicked the button for the Beta firmware update. It immediately hopped up to 34% then stalled. I gave it 10 minutes, but it was still at 34%, so I clicked cancel.

The Bullet is now in an state where its LED display doesn’t come on when I apply power (and a fan is running pretty fast), and the Roast.Time software doesn’t recognize that my roaster is connected. Is there a way to get out of this state?


#2

To update folks (and to register an answer to this topic for future generations):
My bullet is now working fine.

If this happens to you, contact Aillio support, and they’ll send you a procedure (it’s kind of involved, and if done to a working roaster might get you in trouble, so I won’t post it here). That procedure puts a non-functioning Bullet into firmware update mode. I had to follow the procedure four times, each time getting further along in the firmware upload process, but after the fourth try, it worked great.

So yay!


#3

Good to hear you got it working Dylan!


#4

We will try to make the update process more strict, software wise, in future versions. There could be things that throw it off like the roaster being in certain states when trying to update. Happy to hear you made it through to the other end though!


#5

Hi! It seems like I got same problem while update the firmware of my Bullet R1. (Via New Roast Time V2.05 Mac version)

Now the Bullet R1 Fan is running fast and teh display LEDs are all off.

Please help to send me the recover procedure, Thank you!


#6

It happened to me, again, too! Again, I went back to RT1 to update the firmware to 448.


#7

I added some logs in 2.0.6 (releasing today or tomorrow) that should help me figure out why this is happening for some people. Sorry for your issues!


#8

Hi, It seems the last prompt window which says ok to turn the power off the R1 shown to early.
I guess that the internal MCU of R1 is not yet finished the self-programming procedure.

It is better to wait the R1 turning back on-line before power it off.

To other user: After that window show up, I close the APP and re-launch it, and wait to see the R1 connected. Then I can power off R1 to reset it. This my way to avoid this trouble. for your reference.


#9

Interesting, that could be an issue. It usually takes me a few seconds after that shows to actually get to the roaster and unplug, so maybe this is why I haven’t been able to replicate. I will try doing it faster and see if it comes up. Thanks for this information Francis!


#10

Hi! It seems like I got same problem while update the firmware of my Bullet R1.
Now the Bullet R1 Fan is running fast and teh display LEDs are all off.
Please help to me .Thank you!


#11

Hi Void, Try this:

ManualBootloaderModeFirmwareUpdate (1).pdf (197.3 KB)


#12

Thank you so much.


#13

How much time should it take to update the firmware? I completed the above steps after attempting to update the firmware and while in boot loader mode, updating firmware bar has been on 0% for the past few minutes.


#14

Firmware updates take no longer than about 5 minutes total. It sounds like you’re having a USB connectivity issue. Try again, Perhaps with a different computer.


#15

Strange. After waiting for the update for over 5 minutes I closed it out, and restarted the roaster. Wasn’t able to update the firmware on the roaster yet…will try again tonight.


#16

Yeah - my Bullet’s USB connection doesn’t agree with one of my MacBook Pro systems. During roasts it would momentarily disconnect, etc. Updating the firmware using that machine took many times, each time the progress meter would creep a bit further, and finally it completed. At that point I tried a different computer (also a MacBook Pro), and this time it worked the first time, and that machine doesn’t periodically disconnect during roasts either. I appreciate that the firmware update procedure is pretty robust to this kind of thing. On the other hand, I’ve never experienced such a touchy USB interface. Hmmm.


#17

Hey Dylan – and everyone else with USB connectivity issues – I just mentioned this to Matthew. It may be helpful for us to know your year, model, and OS. Dylan’s case in particular since you are presumably using the same cable with two systems.


#18

kafei (and Matthew). The MacBook Pro that isn’t happy with the Bullet (or vice versa) is a 2015 system running Mojave (10.14). The one that is happy is a 2009 system running El Capitan (10.11). I’ll see if I can get another 10.14 system connected to the Bullet, and reproduce (or not) the USB connection issues.


#19

I still haven’t been able to update my firmware to 448 from 444. Tried numerous times and it simply freezes when “updating firmware - 0%” and fan on roaster is stuck running on high speed. I left it on for over 45 minutes to try the update with no luck.

I’ve never had issues with my usb cable and have even tried other cables to rule that out. This is the first time since owning my roaster that I’ve had trouble updating the firmware.

Im using Windows 7 64-bit OS and running Roast Time 2.0.6


#20

I have added in a logging framework so we can help you debug this in 2.0.7. Released for OSX today and should be available for Windows on Mon or early next week.