Updated to V2 and getting error 0032, what firmware should I use?


Yesterday I upgraded all the components on my V1 sn79 and it’s now in big boy pants at V2 with the latest controls. I did a couple test roasts with left over beans and at about 5 minutes in I get the 0032 error and the power goes to zero and the first crack on the software is enabled. I’m able to get the power back up and continue roast. I’m thinking I’m using the wrong firmware. I’m using the beta 553, should I go to the stable 540? For RoasTime I’m using 2.5.5stable.

FYI on the conversion to V2, all went well except for operator error in reconfiguring the wiring harness, got one end confused. Went back and redid it and it is good now apart from the 0032.


Jacob or someone at Aillio? Please. Running stable 553 firmware and 2.5.5 stable. But not.


Per the manual, ErC 0032 is an ambient temp too-high issue. The max operating temp for the Bullet (iirc) was listed in the Specs in the manual as 80°F, but that has been replaced with Maximum Bean temp of 240°C (426°F) which offers no guidance for operating environment. Getting over 80°F ambient has presented a problem for me roasting in the summer, but I wouldn’t think it would be an issue this time of year.

With the lack of consistency in the manual between Specs and ErC description, you probably need to get Aillio Support involved so they can guide you thru trouble shooting. At this point I have no idea whether the f/w still shuts off power for high ambient temps or if they switched to Bean Temp exclusively.

F/w 553 is the current stable release; f/w 556 is the beta release. I roasted with f/w 556 yesterday without issue (V1.5) and was using f/w 553 for 2 (or more?) weeks prior to updating yesterday.



HI Mike and Bab

We have been working on a new firmware ( beta firmware 558) that addresses the ErC 0032 issue.

  1. ErC 0032 when the Bullet starts up and it is very cold. This error should now be a thing of the past.
  2. ErC 0032 when running multiple back to back roast or high power for a long time. If the induction heating gets too hot you will get this error. The threshold has now been increased by 5 deg C to give more margin before this happens.

The problem was in the lookup table that converts a resistance value to a temperature.
Please give this a shot and report back if it has solved the problem.

Jonas - Aillio


Thanks Jonas… I’ll give 558 a try shortly.

In terms of concept, has the Bullet dropped monitoring ambient? is it now Bean Temp based for all temperature-based shut down? Or is there a mix of criteria? If ambient is still monitored we need a number to save failed roasts on a hot day.



Hi Bruce

The Bullet is monitoring a bunch of different temperatures. The “Ambient” meaning the temperatures surrounding the Bullet, and its not referring to the temperature inside the drum.

There are sensors on the Induction board, the IGBTs (in charge of the induction heating switching), the control PCB, the IBTS internal temp, and in a few other locations. If the Bullet is maintained well, then you will never reach a critical temperature - the IGBTs sensor was the one giving you ErC 0032. If you see the IGBT temperature approaching 98, then it would be getting hot and could trigger the ErC 0032

The maximum drum / bean temperature is 330 degree C, and the old fashion bean temperature sensor is 245 degree C. Don’t think you will ever get there.



Thanks for the insight Jonas. Seems like a lot of work has been going on! Any chance you can get someone to update the manual to give us some clues to what the error codes mean?



I have a V2 bullet (not converted) and received this same error. On my first batch of the day (650 grams @ 518F preheat) and then on the second batch which I had to dump mid roast (1kg @ 581F preheat).

I updated to beta 558, re-ran the batch that was botched before updating the firm ware (1 kg batch @ 581 F preheat) without any problems. Then let it cool for a couple mins before beginning the next preheat (same as before - 1 kg batch @ 581 F preheat). It threw the ERC 032 error twice again (See below @ approx. 4:50 and 7:30). This is probably the warmest environment I’ve ever roasted in since owning it - 75F outside, roasting in the garage with the garage door open.


Thanks for the response. I updated to the beta FW and got the ERC on my first two roasts but on the third roast I had a small fan blowing directly on the Bullet and it went straight without an ERC. It was in my garage at about 60°.


Update: the PCB I installed is apparently the culprit. Aillio has shipped a replacement and I sent the defective one to a tech at Sweet Maria’s as Taiwan won’t allow shipments from the US. Aillio may not always be the fastest but they’ve always taken care of any issues I’ve experienced.