White Screen of Death?

I’ve been on RT3 for several months. Today I was going to roast, and this is the screen I received. I tried uninstalling / reinstalling, I tried turning anti-virus off (which I shouldn’t have to do), I tried running as administrator… all to no avail. Does anyone have advice on how to get this app working?

I see this screen every time I launch on my Win10 laptop but after 10-20 sec it becomes the usual RT3 starting screen. I have always assumed it pauses here to connect to the R.W servers but I’m just guessing. If I’m right and you have previously saved the RT3 install file, then perhaps there was a pause in your internet service… ?? If you d/l’ed the install each time then I’m on the wrong track.
Edit- or the more likely reason that the R.W servers were down/busy for awhile.
Btw, RT3.0.82 contains some changes to the sync process with Aillio’s servers. I was told it takes longer to re-sync… ??


I appreciate your response. In my case it never loads even after several minutes. I successfully loaded RT3 on two other computers, so it’s not RT3.

I fixed it after 4 hours. I had to go in and manually delete all of the “Appdata” for RoastTime and then re-install…

Do you still have your local data, i.e. is My Roasts in RT3 showing your roast data? I’m guessing you do.