Windows 10 RoasTime v3.1.0 showing "Disconnected"

Edition: Windows 10 Pro
OS Build: 19041.804
RoasTime v3.1.0

My Bullet will not connect to my laptop. I installed the drivers via RoasTime Settings → install drivers and am using the supplied USB cable that came with the roaster.

Does anyone have any ideas about what I can do to get this working? I have tried uninstalling, rebooting, and installing all of the software as administrator with no change.

I had issues connecting a spare laptop to my Bullet. I installed the drivers, unplugged and rebooted my laptop. Would not connect. Installed the drivers again. Unplugged, rebooted and got a connection.

You could try changing ports and installing the driver again.

I was hoping that would make a difference, but no luck. I am on at least my fifth round of uninstall/reinstall/reboot, and have tried all three USB ports on my laptop. This is very frustrating. Thanks for sharing your experience, though.

I’ve gone thru this several times with mine and in my case it has been the connector end at the control panel… I have a problem getting it to seat solidly and it sometimes drops the connection. I suspect (but don’t know!) that the rear of the housing may get in the way.

In any case, don’t assume the problem is your fault or that of your computer- contact Aillio support and get a trouble ticket started. There may well be an issue with your cable (that would be too easy!) or possibly the control board. Aillio Support will guide troubleshooting.


Edit- After thought… you had Win10 in Administrator mode when you installed the drivers, right?

Thank you. Yes, I installed as administrator and now I have tried the supplied cable and the highest quality cable that I have. Still no luck.

I installed RoasTime on a friend’s computer (Win 10 as well) and used the supplied cable to try to rule out hardware issues, and it did work on their machine. So it does appear to be a driver problem on my computer.

I will get a ticket in. Thanks.

@kuklokragd When you installed the drivers, did it pop up asking for permission and run two scripts?

I had this very same problem. This was solvable my installing the RoasTime version 2 and using the menu item Force Install. I’m commenting only because this pretty easy to solve, yet nowhere is it in RT3 instructions… it was kinda dishearenting for my initial setup, and honestly, USB is such a Windows XP era technology. Clearly this is a tricky Windows issue though.

It ended up working, but not until I had uninstalled the drivers, reinstalled RoasTime as admin, run a manual seasoning batch through the roaster with the USB plugged in, THEN tried to force install the drivers via RoasTime. I had literally done this whole process at least 3 times and the only thing that changed was having the computer plugged in to the roaster after it had run a batch manually.

I know this isn’t the easiest thing to replicate, but if anyone else is having this problem, you might be able to fix it the same way.