Bean Inventory - Adding a new beans does not work [answered]

Hello all,
Adding a new bean has become really difficult and problematic. See the video.

and a simplified video of the same thing showing you cannot enter ANY name at all…

@mark.palmos Interesting that you weren’t able to add a new bean. I just did a test and was able to add a new bean. I’m a Win10 laptop and used Chrome to enter a new bean using RoastWorld. Where you had trouble with data entry I was able to enter in a bean name and a lengthy description (both were copy/pasted into the respective fields). It worked for me…

I’ll probably get shot at by @derrxb for adding yet another instance of INDONESIAN SUMATRA GR. 1 MANDHELING TAKENGON IKA but I did it in the name of testing :slight_smile:

Hi @mark.palmos,

For the first video, you selected an existing bean. The fields are disabled because we do not allow edits to be made when the bean is an existing bean.

For the second video, this is because you need to click the “New Bean: [Bean Name]” option in order to be able to add a new bean with the given name. This is intentional as we’d really like users to avoid adding duplicate beans if they exists. This is also why we changed the flow to ask users to enter Vendor => Bean Origin => Bean Name.

I don’t think we want to change this flow as we’re trying to reduce the number of duplicate beans added. However, I can make the it more obvious that you’d need to click the “New Bean: [Bean Name]”. This is also how adding a new bean works on RT as well. Though the bean origin option is removed.

I think this might be some issue with the UI rather than any bugs. I will make a pass through it and see if I can make any changes/additions to make things easier to understand.

Best regards,
Derrick

1 Like

Thanks for also helping with this @blacklabs. I can also confirm that I added a new bean on my account and it worked as expected.

Hi
When you say I need to click on NEW BEAN, what do you mean? I do not see that option. All I see is “Create A Bean” which SHOULD mean that you are creating a bean, IE a new bean… but this is what I did in both video 1 and 2… so I am a bit baffled. I do not see any other way to create a new bean, unless it is well hidden somewhere?

Where is the “new bean” button, all I see is Create A Bean, and this does not allow me to Create a Bean!

Hi @mark.palmos,

Sorry for the confusion. Here are some screenshots & a video showing what I meant:

If you still have issues finding the button/list option, please let me know.

Derrick

@mark.palmos when you’re in the screen below:

After you type in a new bean name in “Name” you that drop down thing, note the "New bean: “test” at the bottom, if you click that then it leaves what you typed in in that field.

Then you can enter your description:

I know … it is a little but counter intuitive. Me coming from a local client UI with server back end, to a web-based UI, the quirks of web-based UI can be annoying and not super intuitive for me, an old-school client-server type :wink:

Hope this helps…

Ha! @derrxb got more fancy and beat me to it :wink:

1 Like

@blacklabs’ screenshot is right as well.

I can improve this by making the dropdown option for a new bean clearer as I realized that it’s seemed to have morphed into the “Descriptions” box. I’ll get that fixed tomorrow.

Hi,
Yes, it is absolutely not clear, when I see this it looks like I should choose one of the two costa rica tarrazu beans and doing that will allow me to create a “new bean”… I tried about 10x and not once did it seem that I should try clicking on the text which says new bean.

This might just be a difference in interpreting UI. It says more of “Oh, here are two options, Costa Rica T… & Costa Rica Ta…, or a new bean with this name”. In this case, we’d prefer if you choose one of the existing beans.

But if it’s just one option and a truly new bean, I believe the UI is straightforward enough to show that you need to select the only option. The issue that seems to be causing confusion is that when there’s only one option it sort of blends into the description box and is hard to see. I can fix this but I don’t think we want to change the ‘New Bean: “costa”’ section other than making it more obvious that it’s clickable.

I’ll mark this as fixed as I will make necessary changes & you now know which button to click.

Derrick

@derrxb Just a thought here. I think what is confusing especially in @mark.palmos 's screen shot is that you have so much space in between the bean name and the slightly grey text below each of the first two options.

Would it be clearer to have that text smaller below with slightly less spacing or perhaps even to the right? My 2 cents.

1 Like

This could definitely be the issue. Thanks for the additional feedback. I’ll update on here the changes I’ve made to this later today.

Sounds good. Sometimes it’s visual cues. That said, it would be good to hear what @mark.palmos thinks that makes it visually clear to him. :slight_smile:

Hey everyone,

I made some visual changes to the user interface to fix the issues discussed on here. The changes should be live by the time you all see this response. Please let me know if this improve its usability for you. & if it doesn’t, feel free to make any suggestions.

Thanks,
Derrick

1 Like

Thanks, much better!! :+1:t4:

Hi, just a side issue, often, as in the case of this bean, the existing beans have inadequate data, and not being able to edit the existing beans does mean creating a new bean, leading to many instances of the same bean on the database. The choice was made, I guess for the bean profiles to be shared with all users, which is why they cannot be given a personal comment or user rating by each individual user. But in any case, for me, I would want to add a new bean so I could paste the bean seller’s notes on the bean in the Description field, as well as my own personal comments on the bean.

BTW of this, the previous UI, to me, meant "you are adding a new bean to YOUR INVENTORY, so choose between one of these TWO beans. Clicking on either one was not editable, and entering a new name, like “Costa Rica Tarraz v2” and then pressing ENTER did not do what I expected, to create a new bean…