Bullet does not connect to Roast time...says disconnected

I’m out of town this week but should be available to set something up to help you out after the 4th of July holiday weekend. I’ll gladly help out if we can schedule something when the time gets closer.

@here I have a new version of comms for testing - please ping me if you want to try and I will update you to get the version.

1 Like

Yes, please! I was on vacation and just returned. Will be roasting this week so would love to be included in the version for testing. Thanks!

I am having these exact same issues on my Mac & bullet, since updating yesterday.

Hey @greenmancoffeeroasti,

Which version of the communication service do you currently have installed? You can find this information under Settings > Software. The latest version is v1.10.31 and this should have fixed the connection issue described on here.

Derrick

Hey @joshuamwoodrowscfw,

Your RT should automatically have downloaded Comms v1.10.31. Can you re-try with this and update on here?

Thanks,
Derrick

I will have to reinstall RoasTime4 and see.

As Derrick mentioned this version has been released to everyone as v1.10.31 after confirming it fixed multiple people’s issue. Let me know if you still have an issue after updating to this version.

Hello my friend I’m using Mac I opened the Edit the file And I don’t see The reinstall Dependency On software tap,Would you please tell me how ?Because once I update my firmware from 595 to 606 ,There always a disconnection After beep for four times and the power cord goes red flashing

MacOS has no dependencies. That sounds like a failed firmware upgrade. Have you tried upgrading it again? You may need to go into bootloader and do it.

You know what I did to finish the updating of the firmware ?I switch into RT 3 And an updated perfectly to 606 from 595 So I guess to RT 4 has some glitch For updating the firmware Hope you guys can fix it

1 Like

Thanks Derrick, I did yesterday when starting up the machine to roast. Unfortunately after I updated I was able to successfully connect to Roastime and the machine was pre-heating when suddenly it powered off. Power supply is good and not tripped. Each attempt to turn the Bullet back on has been unsuccessful. I hear a slight sound (usual noise) and usual light flash from the USB light when plugging the Bullet it but then no power whatsoever.

Hi Josh, I replied in the slack channel.

I’ve been out of town and life has been busy. I roasted the other day, RT forced an update which I did. I roasted several pounds without any issues. Thankfully this update seems to have fixed this issue.

1 Like

hello all,

just happened to update roastime and am having the same issue as above mentioned. i have tried reinstalling it and it still shows the same issue. I am on windows and checked if everything is up to date. Still cannot figure out why it is saying disconnected. I even tried few different usb cables.

Can you tell us which version you are on - go to settings, software.
Also when bullet is On and connected can you see it in the device manager?

Did you try after the software auto updates? Which versions are you on?

hello, I did the auto update. here is the version I have:
ClientLatest v1.79.0v1.79.0
Proxy serviceLatest v1.31.0v1.31.0
Communication serviceLatest v1.10.40v1.10.40
Dependencies were re-installed. I have a windows 10. Device manager would not see it though, I am unsure if it is the cable now or my ports. Thank you all.

Hey @john.aWje ,

You mentioned the device manager not seeing the Bullet. Can you try the steps listed out here?

I’m having this same issue. I believe I spoke with you in a discussion I started prior to upgrading my V1 to V2. I’ve now changed it over to V2 but I still can’t connect to Roastime 4 or 3. I’m on Mac and have done all the stuff suggested concerning restarting/unplugging.

I saw that some peoples issue got resolved with an update but I just tried with the latest update and still struggling to connect the roaster.

I’m happy to screenshare.