Control panel dead on new roaster

Hi, just received and setting up my new bullet. All seemed fine until I followed the manual guide for installing firmware. When I came to the step about unplugging usb and power cable, the control panel won’t switch on, it’s completely dead.

I’ve tried updating firmware, uninstalling and reinstalling the app, I’m not sure what else to try, I just can’t get any power to the control panel

It sounds like the roaster is in the ‘boot loader’ mode waiting for f/w to start loading. Unfortunately it’s the weekend in Taiwan so you won’t find support around till Sunday afternoon late (6’ish MST in the US).

I don’t know which version of RT3 you have installed but I tested f/w install several times with RT3.3.0-rc5 on both Win10 & Win11. It’s what is offered here. There may be other issues with RT-3.3.0-rc5 but perhaps it will get you thru f/w (and driver!) install to completion.

Sounds like you have it in mind already, but when f/w installs you’ll need to remove power for a count of perhaps 7 to 10 to allow the internal power supply in the Bullet to bleed down and reset the processor. And of course disconnect the USB and then reconnect.

1 Like

Thanks bab, appreciate your help. Tried that version on your suggestion but can’t get drivers to install successfully. Can’t even get my laptop to recognise the bullet is there. Going to try another computer & another usb. I did come across a video by aillio saying to reboot the control panel using a paperclip but I’m hoping rt3.3.0-rc5 on a more up-to-date OS will help.

@bev_watte8tg Paperclip reset is a solid no fuss way to go, Neither the computer nor the RT software will recognize the bullet while in bootloader mode but the firmware will install.
After just follow what @bab said regarding the power cord and USB and you should be good to go!

P.S. I had some issues 3 days in to ownership and a MacGyver style paperclip did the trick for me…


As other’s have said, as of right now we can’t pick up the status of a roaster in bootloader (we are working on this) - so it will show offline, but the firmware install should still run.