V3.3.0 Soft Release

We are doing a “soft” release of v3.3.0. You can download it on our public slack in #roastime by joining here and viewing the this message, but we will not force update quite yet. Feel free to try it out and report back any bugs you find in slack. Below is a change log:

  • Optional software updates (we can deprecate versions to force update at certain times)
  • Logger timeout set to be longer when closing the app to give it time to upload
  • Driver install no longer needs you to choose a download location and does everything automatically
  • Added a keyboard shortcut for entering debug mode
  • Firmware updating was updated to fix some errors
  • Communication with the usb process happened through intermediary main process (renderer->main->usb->main->renderer). I have implemented functionality to have usb have it’s own IPC listener and is able to communicate directly with usb. (renderer->usb->renderer) which should prevent blocking and cut back on resources.
  • When viewing profiles, you could go to the end and it would not show any data in the legend, this is fixed
  • Use config-defined primary temp for Delta
  • Minimize ref roast when building recipe
  • Save table page size setting locally
  • Alert/Edit profile from table for missing green weight
  • Your window size/position is saved and restored when opening the application

Tried RT 3.3 this evening and looks like the lag between clicking milestones and the times recorded is gone. I, personally, used to see a 1sec lag, so, to record a 9:30 FC, I would need to click at 9:29. It now looks to be recording the time when clicked without lags. The Delta temp also looks back to normal…

Meanwhile, there was a Win 10 update in the morning. The installed RT refused to start post the Windows update. The solution was to download the latest one from Roast World, install and then it ran.

1 Like

I thought I saw a similar lag in response. Not a biggy but then some of my event markers are sloppy.

Odd about the Win10 update… sounds like a left over whine from Microsoft about the RT 3.3.0 install but I have no clue how that could happen. Glad the reinstall solved that issue!

My trusty old Samsung laptop died several months back and I replaced it with first a Lenovo/ARM (intermittent crashes) and then an HP/Intel. Both were recent enough that I was offered the Win10 → Win11 upgrade. I’ve not seen any issues running Win11 with RT3 but your problem above makes me wonder if there was something that is a Win10 specific issue. Just speculating out loud.


1 Like

So during pre-heat, i upgraded the software…bad idea…

I was running FW 558. FW 558 is not compatible with RT3.3.

The software indicated there was an issue. I was a bit scared to update the FW from 3.3, since it did not seem to be communicating with the roaster, so i installed the last version i had of RT2, installed FW 591. Then i reinstalled 3.3. Started 3.3, roasted 4 BTB roasts with no problem.

My point here is that you should make sure you are on a5 least the latest stable FW before installing 3.3.

Hopefully this saves someone some heartache and panic.


1 Like

When you say updated the software do you mean RoasTime or the Firmware?

Hello Jacob, i was referring to roastime 3.3