Dead roaster. SO sad to be me

Hey Folks!

Tried to update firmware to the latest Beta this PM and the upload failed.

After that, the control panel would not light up.

I did some investigation, did a “paper clip” reboot, got the three beeps, reconnected the USB, and still no joy. The firmware update would start at 1% then give me a “Roaster not connected” error.

WIndows and see the roaster, Roastime cannot. I tried reinstalling RT, as well as any number of iterations of power on/off, hard reset, reboot my computer, etc etc.

I opened a ticket, but any other ideas of what I could try?

Screen grabs below.

Thanks!

Dan



Hello,

I just had a similar issues not to long ago. I had to go back to the older version of roastime. Once I did that it allowed me to upload the firmware correctly. Then went back to the newer version of roastime.

1 Like

Thanks.

Where did you get the old download? Was that version 2.5.x?

This post I believe has the link for a download.

2 Likes
1 Like

Got it. But if I can download the old, upload the firmware, then upgrade, it should be good, right?

I had to uninstall everything from my pc, then remove the drivers, then install legacy version and update firmware/drivers, then install new version of Roastime

1 Like

Got it working. I didn’t have to go that far - just a cold reboot, load 2.5.6 (stable) and then I was able to force the firmware update.

Thank you, thank you. This is a great group.

I have said this before, the Bullet isn’t a toaster. I should have taken more care. Luckily this community knows everything.

Best,

Dan

4 Likes