Error A-01, black display, no response


#1

I just received a new power pcb unit because there was a problem with the old one. Installation went fine, also preheating, but when I started roasting I soon got the A-01 error and noticed that the exhaust fan doesn’t spin, only in cooling mode on maximum speed.

I updated to the latest firmware (512) and unplugged the roaster as requested. When starting the roaster again, the front display stays black, no voice, only the power pcb fan spins at high speed and a red LED on the backsied of the pcb flashes (LED is right next to the programming connector).

Anyone who has faced this issue before and knows how to solve it?


#2

I haven’t (yet) had a reason the remove/replace a “power pcb”. My first action would be to double-check all connections that would have been affected including looking for pin/connection problems. Things like misaligned connectors, pushed pins, etc. If all is OK, there is always the possibility that the board itself is DOA.

On your original exhaust fan comments, the Bullet does not check/report whether the exhaust fan is operational until right after “Charge”. So, you won’t hear a peep from the Bullet about the fan’s status (even if it is totally locked-up) all the way through the PreHeat cycle.


#3

You may have done this, but the power cycling after new f/w install must be done twice. I’ll guess they compute/save constants at the first instance, then it (s/b!) ready for use after the 2nd cycle.

More likely it’s a connection as PapasCup suggested.

Bruce


#4

I double checked all connections, all the cables are installed correctly.

The strange thing is that the roaster worked fine at the beginninh except for the exhaust fan. After the f/w update the “new” problem occured, so it seems to me as something went wrong during the update, but unfortunately I everything but an expert on these topics.

Also the red LED didn’t flash before that :thinking:

Oh man…I have no clue how to fix this


#5

Regarding that A-01 error, does your exhaust fan spin freely or is it physically stuck and unable to move?

On that “flashing red light” thing, we had another user here that was having that (shown in a video he took of the Bullet). I’m not sure if the flashing red light is actually a problem or some change Aillio made with newer parts. But that other User was basically having input power being affected by running a vacuum cleaner while the Bullet was in operation. I mention this as a thought for you to check your input power, make sure it is on a power connection that is not being impaired by other equipment, etc. Maybe even try moving the Bullet’s input power to a different more isolated wall-plug.

Regarding the problem after a firmware update, that is one reason that I avoid doing it and am on older firmware. Firmware updates on the Bullet can be an odd experience that can result in an unusable unit. It is quirky at best due to the need to do several power-on-resets to get new firmware to behave. There is an older procedure for clearing out the firmware, but I don’t know if it is OK to use for newer Bullet parts.

Open up a “support ticket” to Aillio, or if you bought it from Sweet Marias give them a call to see if they can help.


#6

The exhaust fan runs freely, it’s not stuck.

I tried the bullet on different wall plugs but nothing changes.

I’ve already written to Aillio but no response yet.

Thanks a lot for your contributions.


#7

It can sometimes take quite awhile (weeks) to hear back from Aillio from what several other users have reported here. I’m not personally impressed with the slow support response and feel that Aillio needs to improve in that area.

That exhaust fan failure (getting the A-01 error) after replacing the PCB they sent you could indicate the part is defective that they sent.

Wish I had more to suggest, but there are others here that may have some ideas that we haven’t explored (while you wait for Aillio).


#8

I can only agree with you that sometimes Aillio is very relaxed when it comes to replying to emails etc.
I’m really not very happy with their support either since I’m running a small coffee roasting business amd have customers that are waiting for their coffee.

However, I’ll try to check everything again and hopefully Aillio comes back to me soon


#9

I continually get the A-01 error code and the fan stops although it is not blocked. I contacted Aillio and received a response in less than a day. They suggested a possible cause being a defective impeller motor and provided a method of checking. The check did indicate a defective motor. I replied with that information.
I received their response in 2 days with an apology for it’s lateness but they were ‘moving office.’ They will send a replacement motor.
I couldn’t be happier with the response or result.
In the meantime, I continued to get more roasts by cleaning the IR sensor. An inconvenience but still better than cleaning my previous machines after every 1/2 pound.


#10

What is the status now? Will the bullet start up?
For the A-01 error, please try to do the calibration of the fans? this should fix the problem if the low fan settings are not working. See New beta firmware 507 released

I know that Matt is extremely busy at the moment and they are moving office.


#11

Hi Jacob,
everything is running smooth again. The fan calibration solved the A-01 problem. At the moment I keep getting the A-08 error a few seconds into the cooling mode. It doesn’t affect the roasting or cooling and is no big deal at all, but is somehow a bit annoying. Any thoughts on that.

The critisism was really not meant personal and maybe it was unfair. I was just in a very stressfull situation as my customers were waiting for coffee and I couldn’t tell them when I will be able to roast again.
All in all I very happy with the bullet, have it for about 1 year so far and have done many many roast. Super happy with the results.


#12

No problem, just glad you got it sorted out.
The A-08 warning you can ignore if you’re sure your filter is cleaned and washed. To disable this warning just push the fan setting one setting up or down.