Firmware failed and manual boot failed

@jacob

hi there, i have installed the latest RT3 and then updated the firmware but during the update the USB must have lost connection as now the roaster has no lights on the front and the fan is running while the main board is flashing red. so i tried to redo the firmware even though RT3 says that the bullet is not connected. it didnt work. so then i moved onto the video showing the manual bootloader Aillio - Manual Bootloader on Vimeo and again no success. it seems that i only record 3 beeps when i follow the instructions not 4 beeps? anyway nothing happens and my bullet is still stuck in the “no lights and max fan” mode and RT3 doesnt recognize the bullet via the USB. does anyone have any info or tips on what to try next. i have a ticket logged with support but i figured i would ask here and if/when i get the solution i will post it.

3 or 4 beeps does not matter. If you hear them it is in manual boot loader.
While in manual bootloader, if on windows, check the device manager if the Aillio Bullet is shown at the bottom of the list. If not, you need to install the drivers (while the bullet is still in bootloader mode with the fans spinning at max). After installing the drivers it should show in device manager. Go back and update the firmware and it should work.

@jacob, first off, thanks for taking your time to help me. its much appreciated. i have a few more day of grace before my boss yells at me for breaking his roaster :frowning:

yes i am on windows and i completed the following tasks.
1- got machine into bootloader model , then removed pin but left he machine running
2- connected computer to my modem so that any issues with WiFi could be ruled out
3 - opened up the firewall on the computer
4- confirmed that when the ubs is plugged in that it does show up in the device manager
5- opened RT3.1.6 - says roaster not connected
6 - ran the update firmware to stable

unfortunately the firmware update stage seems to be stuck at around 1% (hard to read). i have left it for 20 mins but there is no change in the %.

am i doing something incorrectly or do you have another suggestion?

sam

@sambuist What are the specs of the computer you are attempting this on? Can you post a screenshot of the device manager with the device there?

Thanks!

the computer is a HP, 64bit laptop, 4GB ram, and a intel celeron N3060 1.6Ghz CPU with plenty of space on the hard drive.

Can you make sure the correct driver is installed? You can follow the instructions I gave here: Rost.Time3 and new Feb 2021 Bullet? no driver

Other than that, do you have another computer you could attempt on? Just curious if it’s something specific to this PC or more widespread.

@mcaillio, i updated the drivers via the method you suggested . that was successful and it shows up under but
universal serial bus devices -> Aillio LTD - Bullet R1 ROASTER FS

when i plug it into my computer and pull up RT it say not connected and then when i go to the roast roast page the words “your roaster is currently offline” disappear if the USB cable is plugged in.

i have tired it on a different computer nut i still cannot load the firmware while in manual boot mode

Same issue here. I tried to update firmware with RT 3.17, and an USB error appeared. After that the screen went blank. I had to sd-gnd the mainboard (only 3 beeps) and then use RT 2.55 to install the firmware again. Then everything works again.

maybe i need to get RT 2.55. do you have a download location @peter425p

https://downloads.aillio.com

@peter425p, i could kiss you right now. spot on.

i installed RT2.55 and then updated the firmware that way. my roaster is back up and running !

thank you all very much for your help

:+1:

Thanks @peter425p - 3.1.7 and 2.5.5 have the same functionality firmware-wise, so not sure what would be different there that makes it work for you, but glad it does.

in bootloader mode, RT3 would not see the bullet when plugged in. it would still say disconnected (symbol was red in the bottom left corner). when i uninstalled RT3 and installed RT2.55 and then plugged the bullet in it said that the roaster was connected (symbol was green in the bottom left corner).

to update the firmware correctly in bootloader mode it needed to be in green mode (RT2.55).

I believe 3.x should be able to update the firmware even if the “connected” is RED. That happened to me and I thought the same but was able to restore the firmware in bootloader mode. I think Matthew was going to try and make that a little clearer…

yes i totally understand your comment and i did try that (maybe 7-8 times) but only downgrading to RT2.55 solved my issue. so i would suggest to anyone that is having an issue to try with RT3 1st and if they cant solve it then the alternative method is to install RT2.55 and try it from there.

1 Like

It was actually Matthew who told me to ignore the not connected light. No harm no foul as long as you got it working :+1:

Had the same issue while updating the firmware. RT 3.17 would not recognize the roaster. In fact the entire left panel went missing. Anyway, uninstalled, installed RT 2.55 and updated the firmware. Now back on track.

Thank you!!! This community really rocks. Yes, there are issues that I face from time to time but the community makes me confident that there is a solution somewhere.

BTW, @jacob, it would be great if a repository of a few older stable RT installers were kept somewhere. I went to the Aillio website to download RT 2.55 but found the option to download only the latest one. Luckily found 2.55 in my Download folder.

Thank you again!

2 Likes

Thank you!
Same issues here.
Bullet crash after 3.17 download
Your post/suggestions fixed it!!

Do you have any idea what Aillio’s longterm fix is?

Cheers

Wolfgang

I 100% Agree.
Most days I do not want to be a beta tester. I just want everything to work same as it did yesterday. I prefer to upgrade a few times a year.

(edit) SILLY ME! that’s what v2.5.5 stable is for. :roll_eyes:

1 Like