Forced RoasTime update, migration to new Bean Inventory system today (3/7)

We will soon be forcing a RoasTime 3 update (3.4.0) to launch our new bean inventory system, which is not compatible with old versions of RoasTime.

*** Old versions of RoasTime will still work, but you will not be able to properly sync your inventory with Roast.World unless you upgrade to the latest version.***

You will get the normal notification that RoasTime is updating, but you will not be able to choose to skip it.


  • Added driver install tour for windows
  • New inventory system!
  • Added ambient too low warning
  • USB library updates
  • Added keyboard shortcuts ( and guide in config, press F1 ) for common commands
  • P/D/F events moved into graph and enlarged
  • Fix for forgot password not working
  • Fix windows USB not reconnecting after unplugging
  • Added calendar view
  • Fix to prevent reloading shortcut
  • Added prev and next shortcuts
  • Fix preheat being wrong when creating recipe from a roast
  • Fix for quit confirmation showing twice in some scenarios

You can read more about the release in our latest newsletter.

1 Like

For all our beta testers.
If your app does not update automatically, you will need to download the newest version yourself from


I don’t know if I’m remembering it incorrectly, but did the interval change on the Y-axis, to 50 degree (celsius) increments? Is there any way to change it to smaller intervals in the settings? I looked but couldn’t find any.

To be more specific, that change is detrimental to my ability to roast well. I would like a finer resolution on the axis, or the ability to customize that.

You can change this in the config page > Roast Config > Chart Defaults

All that I see is this. It sets the size, but not the intervals. The intervals seem to be automatic? What if I want to go to 400, but in increments of 20, rather than 50 degrees?

That is not possible right now as the grid is calculated automatically. I recommend 250C and 25C as then the grid lines are shared between temp and ROR.
I will add your suggestion as a feature request for future releases.



I went back to some old photos & videos I have of roast curves, and as recently as this past December it was showing gridlines every 20 degrees. Now it’s every 50, but that’s not enough resolution for me.

I updated to the new version today and ran a roast. A few issues:

  • I had to manually resync bean inventory (by going to My Beans and clicking resync)

  • Separation between power/fan/drum levels is extremely difficult to see in overlays/current roast using the default theme. Are there any suggested colors that I can manually change?

  • Having the graph cover the power/fan/drum timeline is a little odd. I preferred it when these were outside of the graph

  • A positive item! I love being able to edit roast weight in the all roasts view


I’m surprised no one has reported that the bean inventory system reports zero Kg remaining in stock for every one of my bean entries.

I did a roast on 3/7 using the old RT 3.3 software. Following that roast I was updated to version 3.4. I have not done a roast since but I did check out the new inventory system to find out that the bean descriptions and names are all there. The number of roasts done and the amount already roasted is there, however, as mentioned the remaining inventory for each bean is ZERO. I am not a commercial roaster and don’t use the system, to track what I have left. That number was not working properly in the previous version either and didn’t’ impact me at all.

I just discovered that I can’t “quit” the program on my MacBook Air. I need to use the force quit command to stop the program. This needs to be fixed. Thanks.

I thought this update was going to allow us to input more than one bean for roasting blends. Can’t find that option anywhere.

Hi @geoffreychilds,

I’m sorry if we missed the comment about the inventory resetting to zero. As you mentioned in your comment, the number was not working properly before and this was a result of some issues the old inventory system had.

Rather than copying over data that is more than likely out of sync with what you actually have on hand, we decided that it would be best to start fresh. To keep things simple, we kept all the beans in your inventory. Adding back your green weights should be a one time thing and the inventory system is expected to work correctly after this.

Best regards,

1 Like

Hi @wuhc55kftw,

We didn’t get around to adding this feature yet. However, we do have plans to support it. The main issue is that we’re still deciding how the blends should work in regards to your inventory. This is due to the way users might be roasting blends. As shown in this roasting blends poll, some users roast blends at the same time and while others roast them separately.

As soon as we have more information on this, I’ll ping you to give an update.

Best regards,

1 Like

Awesome, good to hear it’s being worked on.

There was a big discussion about the quitting on Mac among our user testers. If you just do a quit and wait a little while does it eventually quit? I know that it tries to sync some data after you quit, so it might take a little while.

I had to adjust my green inventory as mentioned above and even had to add some beans back in (if I remember that right). Anyway, I roasted tonight and only a few of the beans showed up in the bean selection drop down list. Any one else have this issue? Is there a fix?


Hey @jnorris22100fp,

I think the beans shown are based on the search text entered. Can you confirm that the beans that show up in the All the Beans page are the ones that is linked to your account?

Once a bean shows in the All the beans page, it should show up in the beans dropdown when the correct query is typed in.

Best regards,

updated to new firmware today, the roaster display stoped working. When I tried to unplug the power and usb from the roaster and tried connecting again. The roaster is connected but still the display is not not working but it shows as connected in the roast time software. The roaster is not working. When I tried to go into settings and do another update the error I’m getting is Roaster Not Connected.
Please suggest what should I do.