FW update 591 to Stable 605 issues

My bullet is v1.5, FW591, RoasTime 3.41. Today I tried to update the FW to Stable 605. When update started, it beeped 2 times, then loud fan, very soon the screen showed error " We encountered an issue updating your firmware". I repeated a few times it ended up that RoasTime could no longer connect with Bullet.

I unplugged the power from the Bullet, uninstalled RoasTime 3.4.1 and reinstall Roastime 2.5.7, updated RoasTime to v3.4.1. Bullet is back to normal. However, I still could not update the FW. Any solutions/suggestions?

2 Likes

I have a 1.5 and had firmware upgrade issues until I reinstalled the OLD roastime and updated the firmware from there. It never worked to upgrade in 3.4.1. Worked like a champ in the old version. :slight_smile:

Hi Carson, thanks for sharing. May I ask, per your experiences, if FW605 helps 1.5V as described or it is mainly targeted to V2?

I’ve had the same problem but with beta 605. I’d planned on waiting for the stable version but your experience says that’s a no-go as well.

Not sure if Stable FW605 will benefit to V1.5 for better power management/output, or only applicable to V2.

1 Like

Here’s the change log for f/w updates. 606 is the beta…

Bruce


Update Log
Firmware: 606
Experimental version where the exhaust fan runs at F1 during preheat in order to cool down IBTS and decrease dirt build-up.
Adjusted allowed IGBT frequency for 120V boards even further to increase power at very low line voltages.

Firmware: 605
Increased allowed IR Ambient to 80C
Adjusted allowed IGBT frequency for 120V boards to increase power at very low line voltages.
Added USB command for LED display blink start / stop

Firmware: 602
Fan setting FA now allowed if cooling tray is < C4
Bug fix for V1 & V1.5 Control boards sounding buzzer at startup
More power for 230V induction boards used with lower input voltage and high drum temp

Firmware: 596
More power for 120V induction boards used with lower input voltage
Allows higher temperature on IGBTs - helps with error 32

Firmware: 595
Better support for 120V induction boards used with lower input voltage

Firmware: 591
Support for new Bullet control board revision with new components

2 Likes

same prob here
and since the beta

so is there a “fix” to upgrading to Stable 605 from 591 using the RT software 3.4.1? it always fails for me as well (on M1 MBP)

The question, for me anyway, is whether the result is worth the journey for a V1.5 board. The change log suggests benefit only if you have very low input voltage, which really isn’t a problem in my neck of the woods.

1 Like

where do i find “the old 3,xx” there works

1 Like

yeah, I’d like to know that as well, but I’m the type of person that has to be on the latest version (not necessarily betas though). :slight_smile:

1 Like

Brandon - I’m a tick jaded at this point. It’s slightly off topic, but I made the mistake of upgrading from Mac Catalina to Big Sur without understanding that it would crash my Kingston IronKey (secure USB drive). Problem continued because Kingston didn’t have the necessary upgrade patch ready. Once it arrived, it required a Windows computer (which I didn’t have) to upgrade the IronKey. What’s the point? I went from something that was perfectly stable to a train wreck, lost hours and hours to the fix, and when as was said-and-done, the real world performance benefit of the 64-bit operating system was indiscernible (at least to me). Same thing with IOS upgrades. After multiple experiences with my phone’s battery going down faster than a two-dollar [email protected]#ker, I learned to wait for the XX.1 release :blush:. The older I get, the more I subscribe to the “if it ain’t broke…” mentality.

1 Like

totally get it and apologies if I made light of it. I’ve been a software developer for nearly 30 years now and I’m certainly more cautious then I was even 5 years ago. while I think age plays a partial role in that, I also believe software (and hardware) has gotten far more complex so naturally more challenging to catch all the bugs. in addition, regardless if you are working on a small or large team it doesn’t seem like enough time is devoted to bug fixes. all that to say, yeah we should all be more cautious before upgrading. :wink:

1 Like

Gregg, I have the same question as whether it is worth the effort to upgrade my V1.5 FW to the latest version, knowing it may cause more troublesome. Sometimes I felt the power was low and saw FW605 might address this since mine is with 120V board.

For MacOS try this firmware updater:

For Windows try this one:

1 Like

Hi Jacob,

Thanks for the firmware updater. I’ve ran it but it just goes through the motion of installing the drivers and it repeats.

Any thoughts?

Please elaborate as much as possible:
Which platform are you using?
Which hardware?
Does your R1 already connect and can you use RoasTime?
If yes, you don’t need to install drivers.
Show us a screen capture or describe the messages
Does the R1 make any sounds? Beeping? Fans start running?
If on windows does it show up in the device manager? Before / During updating?

The more specific you can be, the better chance we have of fixing it.

Cheers

I am having trouble too. I tried these instructions too UPDATING MANUAL BOOTLOADER – Docent Coffee.

Trying the firmware updater it reads:
[email protected] ~ % /Users/rodricjohnson/Downloads/firmware-updater-darwin-x64.command ; exit;

This standalone updater is at version 1.0.0.

What firmware version would you like to install? ( (b)eta, (s)table ): s

Will attempt to update firmware. Please wait…

0 / 104 [__________________________________________________________] 0.00% ? p/sFirmware could not be updated: Unable to read 64 bytes from device after getting vars. Please restart the application.

Saving session…

…copying shared history…

…saving history…truncating history files…

…completed.

[Process completed]

I just tried updating it on my windows machine using roastime 3.4.1. I receive the same error as I did on the Mac using 3.4.1: “We encountered an issue updating your firmware, please try again or contact support.”

I tried connecting it back to roastime and it looks unplugged to roarstime. Tried roasting manually and get an Error 6864 while preheating.