How to Playback - the order is confusing and fussy

Hi peeps.
The only two roasts I have done using Playback mode have not worked. Both times, I find the roast I want, put the machine in preheat, click on Playback, and then wait at that screen until preheat is done. Then I charge the machine and click the button that says Go To Roast. But when I go to roast, nothing is happening, so I press PRS, and roast starts manually, no playback, although at the bottom rh corner it says i should click there to cancel Playback… all very confusing!!
As there is no manual for RoastTime, it would be really good to know what the method is to make Playback work. Am I meant to
1/ preheat
2/ while preheating, load profile I want to Playback
3/ click to Playback
4/ click to Go to Roast
5/ watch preheat go up until it has been warming for 15 mins (voice has not come on yet)
6/ charge with beans
7/ if machine automatically starts Playback at this point, good, if not, press PRS

is that it?
why did my playback not happen?

1 Like

Not an answer, exactly, but… I like to use Overlay instead of Playback. While the machine is preheating, browse and view roasts until you find one you like, then select Actions>Overlay. Then go to the active roast. You’ll see the temperatures creeping up slowly as the machine preheats, the clock displaying preheat time, and the Overlay roast in the background.

When you add the beans, if the roaster has already announced Charge then the roast will begin automatically. Otherwise click PRS once to begin the roast. The screen will reset to zero and begin plotting your roast, with the Overlay roast still in the background. The Overlay roast’s settings history is also displayed below the chart, so it is a simple matter to manually change the roast settings to match what was done in Overlay.

The beauty of using Overlay like this is that you can monitor the IBTS temperature curves of the two roasts and modify the profile slightly as necessary to match it, adding or subtracting a little time from each power interval. This is particularly handy if you’re Overlaying someone else’s roast, or your roast of a different bean, in which cases a pure Playback probably won’t produce an exact match of the IBTS curves.

Not very handy for production roasting, but this method works good for dialing in your own roasts.

3 Likes

Thanks Brad,
But I wonder why the Playback wasn’t happening. Could it be that I was peheating for just 15 mins and was not waiting for the voice command to charge?

After selecting a profile for playback it should start as soon as it goes to roasting mode.
Try making a simulated roast without beans (maybe with a low preheat of 100 so you don’t use too much energy) for 6min and change the controls up and down, then try to play back this profile. You should see the controls change.

1 Like

Most likely it’s do to you not waiting for the “charge” voice. In my experience it likes to get the temp stable before announcing.

1 Like

Hi Jacob.
I will try, but surely the Playback mode will hold the roast until it senses that the machine has been charged with beans ?
tx
Mark

It will start running when you start the roast, until then it is just waiting.

Hi Jacob,
I have spent most of today testing the Playback mode and have also made a video showing 4 slightly different ways to successfully Playback, and also I have found a couple of “issues”, which really about the inconsistency of having to manually set preheat time on the bullet, and then NOT being able to actually start the preheat on the bullet. If you do, Playback does not work! This is really illogical and unnecessarily confusing. Anyhow, have a look at my video.

Cheers,
Mark.

6 Likes

Great video Mark. Thanks for taking time to make it.

It’s a pleasure. I have found one mistake though… in the “preferred method” at 3:42, I have added a subtitle over the step where it says you must click “OK got it!”. There is no need to click on this as this popup will disappear when you charge with beans. :slight_smile:

1 Like

Thanks for this great video @mark.palmosfv5l. I’ll pass it on to the Roastime developers so they can provide feedback and changes that can clear a few things up.

Thanks Derrick, it does seem that the process has too many steps, and it should not present you with alternatives which will not result in being able to play back the roast. If you are asked to enter preheat temp manually on the control panel, then it makes sense that you could start preheat on the control panel and resume playback with ONE click Actions>playback. There should not be the message in the top right corner, and it should then go straight into Playback preheating.

Thanks,
Mark.

Thanks for the video Mark. Tent and I have been watching it and have some ideas of how to improve it.

At 2:39 in your video it does look like something has crashed and that RT is not communicating with the Bullet. We will try to find this bug.

About going from Charge mode to Roasting mode automatically this is determined by the Bullet. I think the reason it is not doing it is because the preheat temp is too low and or the weight of your beans is too low, so it cannot properly detect it.

Hi Jacob
Yes, I have noticed that there is inconsistency with this, which is probably, as you say either low preheat or not enough beans.
For me:
1/ If you enter preheat temp manually, and then start preheat on the Control Panel, and then you go to Actions>Playback, then RoastTime should go directly to the playback chart and continue with playback.

2/ You should be able to enter preheat temp in RoastTime, then just go Actions>Playback and immediately preheat should start, showing you the chart.

There are too many extra steps.
Thanks,
Mark.

2 Likes

I don’t know if this addresses your issue, but when I use a recipe for preheating and a separate roast playback for the actual roast, I have found that you have to cancel the preheating recipe before starting the playback or it won’t work. Another issue I noted was that if I let my computer sit until it went into standby while preheating and then tried to open it and do a playback of an earlier roast, it usually froze unless I unplugged the usb connection and plugged it back in first.

@james @jacob This can be caused by the USB on the computer entering power save mode when it goes into standby. If that’s the case, is it possible to keep the chain (USB included) alive?

Thanks for the responses peeps…

Hi James. My typical process is to plug in the Bullet, start preheat manually, then weigh beans, set up my ventilation, get the cooling stuff connected, get my laptop started up, plug it in, get ready to roast…
When the Bullet is ready to “CHARGE” I have not reliably been able to choose a roast to Playback and then charge. This doesn’t work (always). So I manually set the Bullet to OFF, close Roastime, Unplug the USB, replug the usb, open Roastime, find a Recipe/Roast to Playback, and initiate the roast via Roastime… Then it works perfectly, so I always do this work-around.

My laptop is set to high performance mode, never sleeps… so nope, not usb sleeping… not in my case, anyway.
Cheers
Mark

1 Like

Ok, over here it did once, so my time-out is 30 min. now :slight_smile: (Hope no roast takes that amount of time…)
I also did find the (old) Windows configuration screen (buried deep in Windows) and did disable powersave mode on the USB chipset driver. (Cannot say whether it helps or not (yet).)
Furthermore no freezes in the newest software.
(Windows 10 on a Chuwi tablet.)

Maybe some USB chipsets are more problematic than others, or too strict on the protocol?

Hope it helps you to find the cause.

Yes we had that in previous versions of RT, and Matthew is looking into this.

Hi Jacob,
Just so I can be clear on how it is meant to work…
If I start a preheat manually, on the Control Panel, and then while that is happening, I set up my laptop, open Roastime, plug in usb etc… then is is true that i am able to choose a recipe/profile to Playback, and that when the machine announces CHARGE, I can safely add the beans and the Playback will happen? In other words, the Roastime software will take over the manual preheat and resume Playback control via the USB?

Due to my failing to do this a few times, I am reluctant to waste half a kilo of beans trying it out…but if my failures were due to low PH and small load, it should work at 220°/500g every time, right?

Tx
Mark