Impossible to login in RoasTime 4.3.2

Hey @lolleroll , what version of the application are you on? Can you make sure you are on the latest 4.6.9 and try? This should give us better logs.

I am also having this problem on Mac. Version 4.6.9, tried force quitting, restarting, password reset, login as guest.

If I use my login credentials (already reset password, didn’t help):
" auth/authentication-failed

auth/internal-error"

If I try to login as guest:
" backend/unknown

Firebase: Error (auth/internal-error)."

Pretty frustrating.

Hey @retsofekaj6pa9 . This seems to be an issue within the 3rd party auth service we use - we have a task we are working on right now to change the functionality of this. Appreciate your patience!

Okay, thanks for the update!

Still with v3.4.1…
Still waiting for no Beta version 4.x and all is working fine

Please see this post for a potential fix: Can not login to roastime4 - #6 by mcaillio

This did not work for me. I still get these error messages:

auth/authentication-failed

auth/network-request-failed

same for me

This is a long shot, but every time I upgrade RoasTime, I end up getting a warniing message from Windows asking me permission to allow RoasTime to be able to get through the firewall to access the RoasTime host.
If you tell windows: “No”, Windows could be blocking RoasTime from connecting to the RoasTime server and verifying your credentials.

I am not sure of this, but is seems a logical thing that might happen. I am always extremely wary of letting programs access the internet and block most attempts.

Hey @retsofekaj6pa9 @wuhc55kftw,

Are you all on the latest version of RT v4 and trying to Login with Roast World button? Also, are you able to log into Roast World on the same computer?

The issue might be what @billc said in that the firewall might be blocking RT from contacting the servers. Can you try allowing it through the firewall?

Derrick

When I posted my recent reply, I was on the latest version of RT v4 and trying to log in with that “Login with Roast World” button.

My RT laptop is a Macbook. I do not get any popup asking about firewall settings.

I am able to login to RT v3 on that Macbook with my login credentials.

I can login Roast World with the same password,But I still cant login RT4!!! Any body can help us to solve this problem??

Are you able to use the “Sign in with RoastWorld” button?

Yes have tried several times, Can sign in the RoastWorld Web side, but still can’t login on the software.

Can we set up a time to screenshare?

I’d love to get in on whatever solution you guys figure out. Every time I post here, I am asked for additional information, then ghosted for months.

I tried downloading RT 4.6.16 today, and still cannot log in with my login credentials, or the “Sign in with RoastWorld” button.

I am also able to log in to RoastWorld and RT3 with my credentials.

Still looking for someone to screenshare with me if you want.

I do. Message sent.

@here I had a session with @retsofekaj6pa9 today and we found the issue to be an incompatibility with older versions of MacOS. You need to be at least on MacOS Catalina for RT4 auth to work.




怎么解决???难道只能用回RT3吗