Impossible to login in RoasTime 4.3.2

@kitti @craftyroaster @midsummercafebk @fazelnaseri.XMXD Would one of you mind opening RT4, waiting for the update, restarting, and trying to login again? (It will probably fail, but should give us better information).

Also if you can send the logs from /Users/USERNAME/Library/Application Support/RoastTime/logs it may expedite the process.

Hello Aillio team,
I have the same problem here,
Windows10 64X, and I can login Roast.World now, how can I fix it?

1 Like

Hey @zhangjixi2000,

I would like to ask if you tried to log in multiple times? If this is not working, can you try the same password on Roast World?


Hi there, I have the same issue and cannot login. I’m using mac and it also says “auth/authentication-failed”. What’s the solution for this? Should I downgrade the version? Thanks!

Hey @lolleroll , what version of the application are you on? Can you make sure you are on the latest 4.6.9 and try? This should give us better logs.

I am also having this problem on Mac. Version 4.6.9, tried force quitting, restarting, password reset, login as guest.

If I use my login credentials (already reset password, didn’t help):
" auth/authentication-failed


If I try to login as guest:
" backend/unknown

Firebase: Error (auth/internal-error)."

Pretty frustrating.

Hey @retsofekaj6pa9 . This seems to be an issue within the 3rd party auth service we use - we have a task we are working on right now to change the functionality of this. Appreciate your patience!

Okay, thanks for the update!

Still with v3.4.1…
Still waiting for no Beta version 4.x and all is working fine

Please see this post for a potential fix: Can not login to roastime4 - #6 by mcaillio

This did not work for me. I still get these error messages:



same for me

This is a long shot, but every time I upgrade RoasTime, I end up getting a warniing message from Windows asking me permission to allow RoasTime to be able to get through the firewall to access the RoasTime host.
If you tell windows: “No”, Windows could be blocking RoasTime from connecting to the RoasTime server and verifying your credentials.

I am not sure of this, but is seems a logical thing that might happen. I am always extremely wary of letting programs access the internet and block most attempts.

Hey @retsofekaj6pa9 @wuhc55kftw,

Are you all on the latest version of RT v4 and trying to Login with Roast World button? Also, are you able to log into Roast World on the same computer?

The issue might be what @billc said in that the firewall might be blocking RT from contacting the servers. Can you try allowing it through the firewall?


When I posted my recent reply, I was on the latest version of RT v4 and trying to log in with that “Login with Roast World” button.

My RT laptop is a Macbook. I do not get any popup asking about firewall settings.

I am able to login to RT v3 on that Macbook with my login credentials.