Lost data on three roasts

After participating in roasting course I now seem to have lost the data on all the three roast during that session.

The two first roasts are completely empty except for the total roast time, and on the 3rd I can see the setting changes and the time from FC to drop but no graph?

Any idea what cases this and how to fix this would be very much appreciate since the workshop is pretty much useless without the data for reference.

Thank you.

1 Like

I have had that happen to me when I exit the recipe before I save the roast.

I was not able to get the data back.

Not sure if it is the same for you. It would be a shame if you lose those roasts.

Hi @nicolas,

I’m sorry to hear about this. Would you mind giving RoasTime 4 Open Beta and Testing - #5 by kohaii a try?


Sure. I did consider if that could a a reason though I wouldn’t know why.

I just removed RT 3.4.1 and installed RT 4.1.2 but the roasts looks exactly the same :pensive:

Don’t think we can get back the data I’m afraid. I checked roast.world and looks like they are empty.
Not often we hear about this, but did you exit the recipe before ending the roast as @dpiette mentioned?
Perhaps give RT 4 a try and hopefully this should improve things.

I was not using recipes but did “free hand roasting”.
I also already tried installing RT 4. That did not solve it.

During roasting I could acces the previous roasts and I was able to view and use overlay.
It wasn’t until I got home and wanted to examination and compare them that thy seem to have been lost.

1 Like

So just to clarify, the roast were initially saved, you could access them in RT etc. Once the app was restarted they had disappeared? Was this with RT3?

After switching to RT4 did you try roasting again, and these roasts would also not save?

When you said you switched to RT4 and this did not solve it, what do you mean exactly?

The more accurate we can report this issue the better chance we have of finding the bug.

I am not even sure that I closed the program. I properly just tipped the screen down which on a Mac I guess just puts the computer and program in sleep mode or something.

No. The lost roast were made yesterday evening and I have not yet tried roasting in RT4 since installing it this morning.

I ment that the roast where still missing after switching to RT4.

1 Like

Thanks for elaborating.
Let me know if RT4 helps. If you encounter the problem again do let us know.

Thank you. I appreciate your replies and attempts to fix the problem.

I would, though, like follow up on this to make sure there is absolutely NO chance to recover the roasts?

I am sure RT4 will properly help preventing similar problems in the future.

Unfortunately the aforementioned three roasts was made as part of a roasting course which is now become a waste of both money and time because of the missing data. This is extremely unfortunate and I hate to say it but I don’t think this margin of inconsistency in a piece of software should be acceptable.

1 Like

So I had this happen to me before. Recently on RT 3.4.1 about 2 months ago. As far as I know at that time the roast data for this 1 particular roast among 3 roasts that I did that day got “lost” in RW. I know after the finished roasting that day the profile was on RW. I always properly shutdown RT after I finish editing the roast info.

A couple weeks later someone was trying to reference one of my roasts on RW and told me it was blank but it had the roast title, bean name and the date. Because I hadn’t done any roasting since that session when this problem was discovered, I started RT 3.4.1 without connecting to the Internet - because if I did it would attempt to sync with RW and I was previously told that the sync will happen based on the datetime stamp meta data, which ever is more recent for a given roast. I found the missing roast on RT with all the data still intact. I made one small edit to the roast in question, shut down RT, backed up that entire roast data folder to another folder. Reconnected to the Internet and then restarted RT - miraculously it synced and that’s how I recovered that 1 missing roast to RW.

All of this tells me I need to backup my local roast data folder myself because I still don’t trust the integrity of the sync. The above was the only time I was able to recover. Prior times I have lost two profiles completely and another profile data got completely clobbered by the profile of another roast (not sure how that could happen).

My workflow now after roasting for the day is I complete my data entry for each profile on RT, checked that it synced to RW, shutdown RT and then back up my entire roast data folder to Dropbox (basically I take a full copy as opposed to sync to Dropbox). Separately I also run a Python script that someone on these forums very generously shared that also allows me to export all the roast meta data to csv.

I know the guys work hard to get stuff to work, but s*** is going to happen so I take it on myself now to ensure I don’t lose my data. Call me anal about this but it’s my data that I don’t want to lose :slight_smile:


It is very unfortunate yes.

If you can zip your roast-time folder and send it to me then I can see if we can salvage anything.
On windows it is found in:
C:\Users<YOUR USERNAME>\AppData\Roaming\roast-time\

On Mac, I think you need to search for the roast-time folder

1 Like

would that be this one?

/Users/USERNAME/Library/Application Support/roast-time/roasts

That’s the one.

Do you have TimeMachine running on your Mac? If the files were there at one point, you might be able to go back in time to find them again.

Yes, but not just roasts, zip all the other folders as well.

Thanks @damon
TimeMachine is a good point but I have no backup in between what happened.

Here is a copy of my entire roast-time folder:

1 Like

This happened to me as well today. I lost data for 4 roast, from 2 different roast days.
It’s very disappointing considering they were roasts I was very happy with. I have done nothing different than than what I did for the previous roasts. I finished the roast, added the roasted coffee weight and closed the application.
It looks like there is something wrong with how RT interprets temperatures, as it shows the charge temperature as NaN. I would really like a feature in the application to allow me to backup the roast data locally.

What f/w & s/w versions?


Hey @m_r,

I’m sorry to hear about this. Thanks for posting. This seems to be an issue that has started to randomly happen in RT v3.4.1. We’re still unsure of the cause but are working on implementing a few changes on our servers so that the corrupted roast profiles stay locally on your device.

Would you mind giving RT v4 a try: RoasTime 4 Open Beta and Testing - #5 by kohaii? Unfortunately, this won’t fix the missing roast issue but it will prevent this issue from happening to any new roasts.

I looked through all your logs, and I could not retrieve anything, sorry.
I know the guys have added some additional check etc, but since we will not be updating RT3 anymore, I would use RT4.