Roast Time for Windows and Linux

Another week, another release. We were able to get both Linux and Windows version of the new Roast Time 2.0.3 released as well as multiple fixes for all. As this is the first official release for Windows, we hope you have a smooth experience, but we won’t be entirely surprised if you find an issue. Just be sure to let us know so we can fix it.


When you install the new version, there are 2 driver updates that need to run on initial opening of the application. Make sure your roaster is plugged in before these run. If not, plug it in and use the “Force Update Drivers” in the “Tools” section.


Folks, my installation of Roast Time 2.0.3 has been rather a disaster thus far. I started by updating my firmware through the original Roast Time. My first install attempt of RT 2 went OK Iinitially, did have to force an device driver update to get it to connect to the Bullet. Then I attempted to import my existing json profiles as per the email, but this was unsuccessful each time I tried. It said import was successful while at the same time saying there was a problem as only json files can be imported (which these were???) . Same results every time. Then the program shuts down. When i try to start the program again from the start menu , i get a message that the shortcut isn’t valid. so i uninstall and reinstall everything, drivers included and try again, and again… same results exactly. Don’t know what if anything I personally can be doing wrong…help please and thanks.

Further to last email…got RT 3 running, at least this one time, but not able to import profiles. Not sure is this image will appear but I am attempting to send a screen capture of the message I get when I try to import a profile from RT 2.

Also, sorry but what happened to the green bean inventory section that we had in RT2?

1 Like

I had the same issue with the json import. It does not work, but says the import was successful.


Hey @Larz and @Skioutwest ,

The import tool was originally meant for importing from the OSX beta and has some issues on Windows that have been fixed and will be released today. Worth noting that these roasts need to be exported from the old windows version in a newer update (also releasing today).

Did you figure out the issue you were having with the crashes? If not, I would be happy to try help you debug further.

We will be releasing new features regularly. Sorry if there is something vital missing for you - we will try to get to it as soon as possible.

Thanks for the quick update Matthew. I found the source of my crashed software this morning and it was Bitdefender Antivirus that was responsible and I had to manually exclude RT from it to get it to stay running. Also of note and of which you are probably aware, is that Microsoft and Defender both try to get you not to install this update and users must work around that… A few words by you warning users that this will occur may be helpful to all parties… some of us are coffee geeks and less skilled technically than others. Looking forward to the updates…appreciate your support.

I had this same issue, and the Windows dialog is not very user friendly. It only gives one option to stop the install, but you can click “more information” and a continue button appears.


I still need to play around with this new version, but overall it is a much more modern UI…I like it! However I already miss some of the graph display options that were on the old version, such as setting up a fixed range for the X and Y axis, as well as adjustment of the line thickness. Also, unless I haven’t seen it yet, would be nice to have a “full screen” option for the graph, as the default only fills a third of my screen.


I updated the old roastime no problem, and was able to perform the export without issue.

I tried to update Roastime v2 and I am getting an error. The long message appears when launching the app, but quickly disappears so I cant get you details on the message.

Tried the import again with the newly exported files and same issue…


Hi Guys - I always appreciate change, the new Roast Time installed fine for me - I am about seven roasts in and though I might offer some thoughts - there seems to be a lot of screen space dedicated to the control buttons - Fan, Drum, Power - with Drum Temp and especially ROR becoming very small - this seems very backwards to me? I love that the new yellowing, FC etc marks but would like to see both temp & time indicated - as with the Development screen nice feature - but a timer there would be very helpful - I like to roast 1:15 after rolling FC, I do not see where I can monitor that without doing my own calculations on the fly - Otherwise thanks for moving forward!

1 Like

Nevermind….looks like the update finally took, not sure what I did. Also, the profiles imported just fine…I am good to go!


1 Like

Yep, working here now also…including imports.

1 Like

I just updated to the latest version for Windows using the links above. Seemed to update OK then it did an auto update and asked me to restart RoasTime. When I restart it I get a blank screen.


I have just installed the v2.0.3 in windows. However the program does not see the roaster as connected. The old version does see it but not the new. I did the “Force update” but nothing happens. Anyone has the same problem?

Hey Jlee,

The roaster is plugged in when you try to force update? Can you try to run as an administrator? It should pop open the command line to install the drivers.

That’s not good! Can you try reinstalling manually? I will run some tests and see if I can replicate your issue. If it continues, I will connect with you to help you debug it.

Hello, Matthew

Thanks for the fast response. I did try in administrator mode. And the roaster was plugged in. Still I do not get any action at all.

Are you running any anti virus software or anything? Could something be blocking it? We still need to get our windows signing certificate, so there may be conflicts right now. What version of windows are you running and did you download the 32 bit or 64 bit version?

I am in Windows 10 ver 1804, and downloaded the 64 bit version. I do have windows defender on.

Just wanted to say thanks to Matthew for assisting and giving me a tip that fixed it.