RoasTime losing Roast History data and issue with Bean data sync from Roast.World


#1

I have a log-in to Roast.World and for grins have entered (3) of the bean names that I use. However (while logged into Roast.World), running RoasTime displays “No Beans” either at the end of a roast or if I edit a saved roast. The text right above the “No Beans” statement says “Please Log in with your Aillio ID to see your beans”. With RoasTime running, I’m logged-in within the RoasTime app, and I’m also logged-in to Roast.World where I can see my Dashboard, My Beans (with the 3 beans entered), etc.

What “secret hand-shake” is required for RoasTime to think I’m logged-in to Aillio and display the beans entered into Roast.World? I’m missing something or am experiencing a bug and can’t figure out which one is afoot. :thinking:

PS: I’m running RoasTime 2.0.8-beta and Firmware 475.

One more thing that just happened. I decided to Log-out of RoasTime via the icon in the lower left of the screen and log back in. Prior to logging out, I had (5) roast records from roasts I had locally saved within the software. After logging out and logging back into RoasTime, those records are now gone and now I have nothing in the “Roast History”. :face_with_raised_eyebrow:


#2

In RoasTime (I’m using 2.2.1 alpha, f/w 500), select a roast, then Edit. Above the drop down selection for Beans is an option to “Sync Beans”. That ought to get RoasTime to display what’s in your beans list in Roast.World.


#3

I’ve not seen a “Sync Beans” selection above that drop-down bean selection in my version of RoasTime. If it was there, I must have missed it. Thanks for the reply and I’d like to try your idea, but now I have no “history” to edit.

Yesterday, I thought maybe a log-off from RoasTime and back on might help, but it made matters worse (at least for my “Roast History”). The simple act of logging out and logging back into RoasTime removed the (5) saved roasts in my “Roast History”. That is exactly all that happened. My saved roasts were in RoasTime before I logged out and completely gone when I logged back in. I didn’t make any changes to the software (still version 2.0.8-beta), no firmware change , nada…just that one simple exit/re-entry action from RoasTime.

I’ve been trying to find a way to restore that missing history and can’t see how to do it. I searched for some threads on my wiped history problem in RoasTime and didn’t find anything. I did find that as RoasTime was upgraded to higher versions, the database was changed such that there are no .json files that can be exported or restored. The Aillio folks said that it would be too difficult to restore data given the changes made to the new database. So, I’m thinking that my wiped roast history cant be restored. I’ll just hafta wait until I need to roast again and see what I can do at that point.

It does bother me that the roast history data could be cleared by simply a log-off/log-on to RoasTime. When I see things like that happening, and with no way to recover the data, I’m inclined to wait until the software becomes more stable before saving roast data.


#4

I’m using 2.2 Beta and when I edit the profile, right above the bean selection, is a sentence that says:
Bean Selection (Visit roast.world to add more beans to your list) - Sync Beans
Sync Beans is underlined.

Not sure that will help your issue but that’s where you find it. Have you tried Import Roasts under the tools menu? Seems weird that your history just vanished into thin air.


#5

Thanks Wayne. I did read that very “Visit Roast World…” statement (just yesterday) before my roast history was wiped by the software. I didn’t notice a “sync” statement/link in that area when I was reading it. If I still had my roast history, I could view one and edit it to check for that statement again. Since the roaster doesn’t allow the user to set the bean name up-front, I’d rather not go through a roast to check for the “sync” thing. I just roasted 3lbs of coffee on Sunday. If there is a way that I can check that statement sans my missing roast history or without having to complete a roast, I’m “all ears”.

I did see the “Import” under the Tools menu, but that is for dropping a .json file that I don’t have available. From what I read on that subject, the .json file export and import are no longer useful for those of us that started using RoasTime after Aillio changed the database design.


#6

Odd behavior. I recall someone complaining about this sort of thing back in January but don’t recall anything recently.

What did you find going to Roast.World on your browser and logging in? Were the roasts saved there? Doesn’t seem likely but… ??

2.2.1 alpha resolved a lot of issues. And now 2.2.0 prod is available. (Wonder why they didn’t use 2.2.1 prod… ??)


#7

I have no roast records in Roast World, just the (3) entries of beans that I entered there for testing this whole thing. My roast records that got wiped were local on my PC that I use for running RoasTime and the Bullet.

I’ve been using the 2.0.8-beta of RoasTime simply because I didn’t want to be on the bleeding edge of releases while I was doing my seasoning and first few production roasts on the Bullet. Now that I’ve gotten through all that with (7) total roasts, I can move up a release or two in case the bug I encountered was corrected along the way.


#8

Just for grins I decided to update RoasTime to version 2.2.0 (from 2.0.8-beta). It had no effect on the problem and the roast history appears to be gone.

My concern is not knowing how that local RoasTime saved history is managed or how to recover it via the existing database design. If this particular problem keeps repeating itself, then RoasTime (for me) will be a “one and done” tool. I dislike having to consider it, but may have to give Artisan 1.6.2 a try in hopes that it has better management of saved records. I’m not claiming that it is any better, just looking for a stable piece of roast software to use with my Bullet.


#9

Assuming they use Windows services for deleting files and if you haven’t emptied the Trash Bin, the roasts ought to be there (though file naming may be an issue!). Being there, though, may not make it easy to get them restored.

Need some help from @Jacob or one of the s/w developers.


#10

I checked my Notebook’s Win 10 trashbin and there are no files that have been moved there since well before I got the Bullet. I recall reading a thread (here) where an Aillio person said that the new database design would be too complicated to walk the user through roast record data recovery. I think this is something they need to fix because the data seems vulnerable (to me) and should have some backup location that can be called upon for recovery in the event of a hiccup. :roll_eyes:

This problem won’t stop me from being able to roast, but it does affect one of the neat features of this product in having graphically generated roast records for reference.

PS: I updated the title to reflect both issues I’m seeing with RoasTime. Not saying anyone else is having the same problems, just that I’m having poor luck lately with RoasTime. :smirk:


#11

Hi Papascup, I’ve not read all your posts on this subject entirely, but perhaps the message I posted on march 23 in the thread “2.2.0. feedback” can help you. In short, if you start RT you think you are logged in, but in fact you are working locally. If you “log out” (in my opinion not possible because you are not logged in) and login, you work in the cloud. Then you can see your beans but not your local roasts anymore. At least, that’s what I found in version 2.2.0. Perhaps it’s the same in 2.0.8. But again, have a look at my post please.


#12

Thanks Bertje. I just read your post (which for anyone else is located here):
https://community.roast.world/t/2-2-0-feedback/1633/3

I’m gonna bet that your thought is exactly what happened. I wasn’t aware of the thing about being logged-in preventing me from seeing my locally stored roast history. I’d love to confirm your idea, but in my frustration today with the software, I did a sudo-clean removal of RoasTime. I have a fresh installation of version 2.2.0 now, but can’t test your thinking because of the RoasTime software replacement.

Thanks to everyone that responded…its a good community here of helping folks. :+1:


#13

CA few thoughts here…

I’m on a Mac, but I’ve had 2 versions of RT on my machine at once, and deleting the older version, did not result in loss of roast data.

Another thought, is it possible you have multiple logins and as a result multiple databases with roast data?

Lastly, I wonder if your data currently resides on your machine in 2 different DBs, and if one could write code to merge the DBs.


#14

From day-1, I’ve only had one logon to Aillio and was not running multiple versions of RoasTime. So, that wasn’t what was causing me a problem. It is far more likely that the (unknown to me) discovery that Bertje reported was why I could not see my local Roast History. I never had any online roasts recorded, so it was all local roast history database that I was seeing. When I do my next roasts, I’ll save them locally just as before and verify what Bertje reported and expect it to be what happened.


#15

I saw your post in another thread regarding USB driver install/uninstall madness and was thinking there might be a connection there. I’m not using Windows for my Bullet, but I’ve got some experience…

The folders @Jacob suggested removing for the “complete uninstall” are also the ones that I strongly suspect in a Windows setup would contain the local copy of your RoasTime database, which could explain the loss you experienced.

I’d found those files only because I went looking for them with the intention to see if I could extract some raw roasting data to play with, since there doesn’t seem to be a native “export data” function anywhere, but of course, the database is encrypted enough that I can’t do that without a key I don’t have. :frowning:


#16

I appreciate the interest in helping. All that stuff that I reported in the Artisan software thread was well after the problem I reported in this thread and unrelated. The one thing that preceded the problem with not seeing my “local” Roast History in this thread was logging out of RoasTime and logging back in. That is the very thing that bertje1959 had also seen and suggested had caused my problem. I’m certain that his finding is the impetus of the problem and was something that I had not previously known about the RoasTime software.

All that stuff I shared about the “driver issues” that led me to removing the (2) subfolders was a result of having given up on the problem in this thread. I’d decided to see if Artisan would be a suitable alternative to RoasTime. Yes, it is likely that removing the (2) sub-folders (suggested by Jacob) would also remove the local Roast History. But I had not done any of that stuff until I’d exhausted trying to solve the problem in this thread and had decided to move-on from RaosTime.


#17

That might have been what happened, that deleting those folders deleted your guest roasts.
However the problem you had if I recall was not a driver problem, but a problem launching RT right? Driver issues are normally solved by deleting them from device manager, but what people forget is that you might have to do it many times until windows looses the “list” of drivers. So you uninstall + delete then unplug USB, and plug it back in (no need to restart windows if it tells you to do so) and you will have to continue on this procedure sometimes up to 20 times! then finally it will be uninstalled and you can go from there…

Of course we encourage you to use your Aillio ID and be logged in when roasting. Then you will always be backed up and can see your profiles on any PC.


#18

Thanks for the reply Jacob and either I’m not being clear or people are not reading the thread (for which I’d hardly blame them). Once again, I did not delete those folders when I was having the Roast History problem I have reported in this thread. I deleted those folders in a totally separate thread (well after my posts here about this issue) having to do with an attempt to install Artisan. It has nothing to do with why I could not (originally) see my local (guest) Roast History in RoasTime.

Please see post from bertje1959 several posts above. That is what happened to me and is completely associated with not knowing that RoasTime prevents you from seeing your local (guest) roasts while logged-in.


#19

Just one more thought for you Jacob. I’m aware of the social sharing of Roasts that has been heavily designed into using the Bullet. However, I would not choose to share every roast that I do as it would be wrong to do so. I just finished (5) seasoning roasts and my first (2) production roasts this past Sunday. None of that stuff belongs in a public database of roasts. If I have a particular roast that I feel is worthy of sharing, I would do that.

To assume that we all (as Bullet Users) need to be logged in and sharing every roast makes no sense to me. I think you guys need to think a bit more about allowing your customers to choose when and if they want to share roasts without blocking the local Roast History just because that User chooses not to be publishing every roast.


#20

Agreed I like the cloud “backup” idea of my roasts and being able to see them on any other browser device. I see no reason for them to be public unless I choose to share them. Most cloud operations take a similar default I think.