RoasTime question

Hey guys , I’m pretty new here. Just got my bullet couple of days ago. I did my first seasoning roast yesterday. This might be a stupid question , but why is the drum temp looks like a stock market ? I`ve seen many profiles from different users and it looks like a normal line… mine is jumping up and down.

Thank you for your feedback.

Wow - this looks exactly like some of the early IBTS alfa firmwares I tested back in December 2018…
The blue curve you are seeing is the unfiltered IBTS sensor output - the spikes you are seeing is when the drum spokes passes by the sensor.
I think you need to (force) update the firmware

New V1.5 Bullet user here with IBTS and been home-roasting for 20yrs. I get the same kind of graph for Drum temps on the (3) seasoning roasts I’ve done thus far. Checking the Firmware that came with the roaster (from the March 2019 shipment to Sweet Marias), the Firmware version is “453”. In the Update Firmware screen, I see that “475” is the current “stable release” and that version “500” is the current “beta release”.

I can’t find any Firmware release notes (by version) to see what was changed in each release. If I do a search (here) for “firmware 453” or “453”, I get no results. Crawling over this site, I haven’t found any release log of the various Firmware releases. I’d like to know what is going to change and whether updating would affect things like this “drum temp” graph.

Upgrading to 475 would, at minimum, smooth that graph out. (I got one of the units from the same batch, though mine came with 475.) I haven’t done the update to the 500 beta yet, and at the moment don’t plan to. (I’m going to try and keep my updating limited to taking versions that either solve problems I run into or get me new features that I really want, and I’ve not seen anything suggesting the 500 beta will do either for me.)

Thanks for the reply. I’ll go ahead and bring the Firmware to “475” based on your information. Like you, I’ve read the posts from users with version “500” and it seems a bit buggy right now, but it is “beta”…

Does “475” also help with the frequent fluctuations in the ROR graph that gives it a jittery appearance? I’ve not found any setting (yet) as to the ROR sampling interval. From the frequent swings in the graph, I’ve wondered if ROR is being sampled more often than every 30-60 seconds.

Without seeing your RoR graph or posting one of mine, I think you’ll find it still looks “jittery” in 475. Watching it update during my session yesterday, it is–if not real-time–definitely sampling more frequently than that. I know I found myself kind of trying to visualize a smoothed trend line through it…

My RORs are looking similar to the one posted above by the OP.

After just downloading and installing the 475 update, my Bullet is now locked-up with max fans running and no ability to interact either manually or via “starting a roast” in RoasTime. Now I have a new problem to solve and hope that I can either get back to the 453 Firmware of find a workaround to my roaster now being unresponsive. :thinking:

I’ve also reset the Bullet power, restarted RoasTime, etc with no effect upon this new problem.

Oh, no. I’ve got no suggestions other than what I’ve seen elsewhere here–given that I’ve not yet needed to do a firmware update, I haven’t had the opportunity to have problems with one.

Hey, @jacob, @jonas, @matthew, @eli, are you guys reading this thread? ALL of your new users are confused about what version of firmware and software they should be using and why.

All we need is a single web page with a table of about 12 links on it (with descriptions). This is a VERY small thing to ask. It shouldn’t take anywhere near a day to get it done. It doesn’t need to be pretty - only factual.

PLEASE help us out, here!

2 Likes

I got it sorted by trying one more thing. I’d tried resetting power on the Bullet and also shut-down/restarted the RoasTime software (ver 2.0.8-beta) several times with no change in the problem.

So, I decided to unplug the Bullet’s USB cable just at my notebook PC-end and then reset power on the bullet with the USB cable disconnected. That action freed up the Bullet. It began going through its normal power-on startup process. Seems the USB connection had to be reset (by unplugging it from the PC) after the Firmware update. It was odd, but I’m an old PC-guy and know that USB connections can occasionally get into weird states. My guess is that the firmware update left the USB connectivity in some odd state that caused the problem since that was the only thing that had been changed.

Back to the Drum temp on the graph. The 475 Firmware update did solve the Drum temp graph issue and it is smooth now.

ROR is the same with 475 and I haven’t figured out why it fluctuates so much in so little time. But I also don’t know where they are sampling bean temps or what is happening in that area of the drum. ROR swings quite far at times (10-15 degrees F) which can be seen in the OP’s graph. I see that same graphic behavior on-screen in my roasts. My guess is that the flickering Bean Temp changes that I’ve seen reported on the Bullet front panel are creating noise in the ROR graph. I just visually look at the overall ROR trend and am disregarding the spikes for now.

What version of RT are you using and have you loaded the proper drivers?

I think you’re reading the ROR off the wrong Y-axis. You should be looking at the scale on the right, labelled “Derivative.” That trace is really only showing about 4-5 degrees, peak to peak, within a span of about 10 seconds. That equates to less than 3 degree excursions from what you might consider to be the “actual” curve.

The ROR plot is probably just a point-by-point differencing of successive temps. Any jittering in those temps will get exaggerated by the differencing. On top of that, you’ve got the zoomed-in scale of the right Y-axis to make it appear far worse than it really is.

I think the moral of this story is “don’t sweat the jumpy ROR plot.”

I haven’t been (knowingly) using any zoomed-in scaling with RoasTime (ver 2.0.8-beta). I’ve been just viewing the default screen that comes up without changing anything (yet). I am also focusing on the right side of the screen (the Derivative). Yes, I’m currently not “sweating the jumpy plot” as I mentioned in my post by “looking at the trend”.

I’ve built my own gas-fired drum roaster about 10yrs ago and do have some understanding of drum design, thermocouple choice, placement, etc. I’m no expert on the Aillio, just trying to get used to what I’m seeing on-screen. :wink:

Cool. People come from different backgrounds. Not everybody is up on their sampling theory.

When I say “zoomed in,” I only mean that the right scale is much finer than the left in terms of value of parameter per pixel, not that you’ve actually hit a zoom button.

It sounds like we’re on the same page.

Good stuff and thanks for the clarification Celtic.

Wayne, I forgot to check on your “drivers” thought and I expect you are referring to an “Aillio USB driver”? I’m using Windows 10 on my notebook and don’t see a specific “Allio USB” driver in the devices list. I’ve also been rather confounded at times regarding the requirement to install some specific Aillio driver. I thought installing the current release of RoasTime software included the required drivers, but that may be incorrect. Do I still need to download and install a discrete USB driver?

PS: Looks like some people have reported that Win10 doesn’t show the Aillio USB driver without the Bullet plugged-in, so I need to do that and re-check the installed drivers.

Thanks guys for all of your feedback. I will update the firmware today and let you know what happens.

I think you’re right that you don’t need to install the drivers for a V1.5 and RT 2.08. That is what I installed and firmware 475 stable. i’m not changing a thing until all these issues i’m seeing cease.
My machine seems to be working just fine.

From the post announcing firmware v.500, @jacob’s announcement doesn’t say anything beyond “now shows the time after first crack in the clock display after pressing F1 to mark first crack. It will switch back and forth between total time and time after FC.”

That’s not anything I realized I was “missing,” and so, yeah, by itself that’s not enough to get me moving off of the “stable” firmware train.

I believe when I upgraded my firmware to 475 after retrofitting the IBTS kit, the instructions said to restart the Bullet a couple of times by power cycling the mains cable with the USB cable REMOVED from the PC. That may also be a required power cycle with nothing plugged into the R1 after completing a firmware update to 475. Certainly I did not experience the zombie loss of control that you have been reporting.