Roastime V3.4.1 Not connecting on both Mac and Windows PC [Solved]

Been roasting fine on my Bullet V2 on both my M1 mac and Windows laptop Version 11. I updated to roastime V3.4.1 and now it tells me to install my drivers again and it’s not letting me connect to the roaster. the bottom left corner just keeps flashing with a yellow and red light. Uninstalled and reinstalled all drivers on my windows machine, followed all the instructions to reset the roaster. Nothing. Anyone can help? We are a small batch roasting company and now we can no longer use any of the profiles that we created and are stuck eyeballing all our roasts. This is very frustrating

Hey @pinonnfk ,

What version were you using before? Does it have the same behavior on both Mac and Windows (flashing yellow and red)? If it’s doing the same thing on the Mac, it is probably not a driver issue.

I would check the process manager and make sure only 1 instance of RT is running (assuming you haven’t restarted your computer).

Only one instance is running. I’m using V3.4.1 on both mac and windows PC. I updated them on each computer. Then when I tried to run it on mac it wasn’t connecting so I tried my PC. Then as soon as I plugged the roaster into my PC it asked me to install and update drivers (this has never happened before) so i followed all instructions but now it’s not working at all when i plug it in. on the right it shows a yellow light - I can still change the PRS features on my roaster from the software but when I start roasting it says that it’s not connected.

Version i was using before was V3.4.0 I believe

May be unrelated to your issue but having the roaster connected/disconnected light switching back & forth was something I dealt with in the past. On my roaster (Jan 2019, V1.5) there’s a problem seating the USB cable in its connector on the rear of the control panel. I have always suspected it’s just the accumulation of tolerances unique to my particular Bullet/cable combo, but the connection can be a little touchy- a small bump and the cable connector shifts a tiny amount and the connection drops out. I was usually able to just reseat the connector and all was good. The recent USB replacement cable seems to have corrected issue.

So the suggestion is to try seating the connector a little better. If it makes a difference, don’t do what I did and just live with it- get a replacement cable! :slight_smile:

Bruce

Thanks for the additional info. The yellow light says we can see the roaster on the USB, but we can’t claim it (for whatever reason). This is usually due to the device being claimed by another process or the driver is returning some error if the light is staying a solid yellow. If it is blinking, it is actually losing visibility to the roaster and may indicate an issue with the connection to the roaster.

Do you have the old version still around? If not we can send you a previous version and see if it works to rule out any hardware issues.

Thank you Bruce. I tried that and also purchased a new cable but having the same issues.

Yes. I downloaded an earlier version but when I run the software it tells me that a new version has been downloaded and needs to restart. I clicked ‘later’ and tried to run it with the older version and I have control of the roaster but the connection still flickers from Red to yellow. This only happened after I upgraded. I have had no problems up to now

I know you probably have, but just to make sure - have you restarted both your computer and the roaster since upgrading?

I let the roaster cool down amd have since unplugged it. It is now working on the Mac but not the PC!! But I am so happy that it is working on the Mac!! I am going to update windows on my PC and report back if it works.

1 Like

Still getting same problem on PC. When I run version 3.4.0 it works but then it automatically updates to 3.4.1 so I habe to run the.exe from the previous version

I had the same issue with my 2nd windows PC, what I did is to remove the USB driver of the Bullet first from the PC and then connect to the Bullet to reinstall the driver from zero. And it works. Good luck.

1 Like

Could you show your device manager and as much info as possible about the aillio bullet driver?

I removed the USB driver. My mouse and accessories stopped working. I rebooted my PC and reinstalled USB drivers. Then rebooted again and performed a fresh reinstall of Allio software and drivers. Rebooted and everything works fine now! Was a lot easier on the Mac but uninstallimg USB driver was the trick!! Thank you!!

Worked perfectly!!

Great !