RoasTime Ver. 3.2.4 Update

Why is there no change log about the new update?

@jordan - if you click on the bell in Roast Time it’ll trigger the notes/alerts window, the change log is there and on roast.world too.

I believe I need some help with this update.

After the automatic update to 3.2.4 I went to do a roast. There is an active connection to the roaster that is recognized by the program. I can overlay or set up a roast but I get no input of temperature or any other control inputs from the roaster. I see just zero’s as if my computer screen is receiving nothing.

I rebooted the computer to no avail. The computer recognizes the roaster but can’t measure input or control it. Thanks for any help.

Update a few minutes later. The software said my roaster was offline. I quit the program and removed the cable and reinstalled it. Now it appears to be OK. However, I still had a connection previously so the cable appeared to be functional or perhaps only partially functional.

I’ve seen this sometimes if my laptop goes to sleep. In another hobby forum they advise looking for settings related to USB sleep timeouts and disabling them…

2 Likes

This applicable to Win10 too or specific to Mac?

Edit: well you answered that one for me! Thanks for that link Stuart.

If it’s fun and drama you seek Bruce, Windows has you covered :joy:

Try Windows with a non-Intel processor. It seems to be ok but every time I see something “odd” I can’t help but wonder “is it the RYZEN processor?!” Yeah, yeah… I drank the Intel KoolAid!

And Win11 is apparently just around the corner. Ugh!

When this happens try restarting the Bullet as well.

Is anyone else having trouble with this update? It updated yesterday while I was roasting. I restarted RoasTime while connected to a powered-on bullet, and RoasTime Froze up on me…ended up having to roast manually after restarts didn’t help. After I was done I updated the firmware also, and everything seemed happy.
Today I booted up the laptop (Win 10) and the roaster, and all looked good. When I started my first roast, however, RoasTime charting was frozen again…the whole graph window was empty - no lines, no values for P, F, D, etc. I restarted a couple times and it was the same each time. Finally, after the 3rd restart of the software I started clicking between my beans, roasts, etc - just switching around to different parts of the software. Then I went back to my current roast and it start showing the roast. All the times were wrong, but at least it was working. The next 3 roasts after that were normal.

I think there is still something wrong with this update. I am up-to-date with the latest 3.2.4 RoasTime, and the latest stable version of Firmware. I got it working, yes, but I don’t know how/why. I’m worried that my first roast of every new session is going to be messed up in RoasTime, and have to be done manually. Anyone else having similar issues, or found a fix so the first roast works?

Hey @smallbolivianlych - I am testing quite a bit today after seeing this thread. I have not run into this as of yet on any of my laptops. Let me know if it still looks good next time you roast.

This just happened to me as well. I get a notification that an active roast is happening but then when I switch to the roasting tab the numbers are frozen at their initial readings and there are no graphs. I restarted roastime multiple times while my roast was ongoing and also restarted my PC but it hasnt worked. I did the roast blind and will hold off on a second roast.

Dell xps 13 windows 10

I got exactly experience as @smallbolivianlych just yesterday. Three roast batch wasn’t able to log.
And then it works as normal for the next 5 roasts, except the firmware upgrading.

A minor issue is the power/fan/drum bar runs faster than the timeline.

do this if the numbers are frozen… Unplug the USB and plug it back on wait for 10sec.

1 Like

As I wrote above, this worked for me as well. It might take 2 or 3 tries but I got back function from the program.

I preheated the roaster, plugged in USB, then started RoasTime, and it froze when I tried to use it. I unplugged USB, cycled through roaster settings manually (cool, shutdown, off, back to preheat) then plugged in USB again. This time it worked.

Next I tried starting RoasTime with USB unplugged, then plugging in USB - RoasTime just kept the red circle and said the roaster was not connected. Nothing I did changed that. I had to start RoasTime with it plugged in for the software to detect the roaster.

This post was flagged by the community and is temporarily hidden.

1 Like

We are an extremely small team and we do test each release. There is a large amount of OS/Architecture combinations and unique setups even within those (other software/hardware interference). The majority of our users do not have issues and we try to help those that do. We will continue to test on as many platforms as we can, but it is incredibly naive to think that software has been or will ever be perfect. Even Facebook with its massive resources was down for an entire day the other day.

We are giving you RT for free. You do not have to use it if you don’t like it and we will always welcome constructive criticism, but your comments are not that and your attempts to put the team down is very unbecoming.

4 Likes

Mcaillio.
One thing you could do was let people choose for themselves whether they would update software or not, and I hope you take it seriously. It’s just a yes / no button
It is frustrating that time and time again I have to experience a well-functioning machine and then after your update, have to struggle with some unnecessary errors.
Maybe the software is free, it was definitely not the machine.
I was certainly not aware that you think the software is free on your sales website, it says the following: quote : directly from europa.aillio.com: (Details of each roast can be digitally recorded and saved as Roast profiles which can then be played or shared with other users.) Quote end .

It sounds like some software is included, as you can not record on the Bullet itself
Please see the problem from another side, as not everyone is super computer interested, but may well find out how to roast good coffee.

1 Like

Which is I think, Matthews point; if you don’t care for the software, don’t use it, the Bullet will function manually without it. Or you can experiment with open source alternative like Artisan. Their software isn’t perfect either. However I would agree that an opt-in to software updates couldn’t hurt. But in line with other much larger software companies, Aillio might require you to demonstrate an issue is also present on the newest release (ie they will not provide a patch to say 3.1.x)

@smallbolivianlych @alexguo @cushdan

I was able to reproduce this bug and will have a fix out. In the meantime, you can bypass by not starting roasting until the application is already open.

1 Like