Unknown Bug that erases roast titles, corrections, and descriptions

I’v encountered a bug that erases roast titles and descriptions. It even seems to erase corrections to “yellow” time and “FC” if they are made after the roast has been done.

This all started after I upgraded and did a roast sync. But my roasting shed does not have internet, and now any non-sync’d roast could be erased at anytime.

Has anyone else encountered this?

Tech support does not know what the issue is yet, but I have reached out and they are looking into it.

1 Like

I recently had a roast completely disappear. Really have no idea if it was something I did but I don’t think so. Unfortunately I can’t offer much more than that.

Actually, I just had at least one whole roast disappear today.

Difficult to keep track, because all the roasts end up as “untitled”, but I know at least one entire roast curve is no longer there.

I’m so tired of issues with this machine!

I just worked out some other issues, and it has changed the way I roast now, so it is CRUCIAL I have all the details and records, so I know what I am cupping.

Really horrible time to have this bug.

Would love to know what you’ve figured out that changes your roasting (but probably another topic).

No, the Bullet has been horrible. Nothing to share worth your time

I get that people are happy with things, but idk, just every step, there is an issue, I bought some parts and they are usable, but disconcerting:

The rubber retaining ring had a weird chunk out, not sure how much air disturbance it causes, but it just is unsettling.

Very different sizes for the chaff basket filters. One is too large and the other too small. They both are ok, but probably should be something in between.

The chaff filter “handle” had its securing hole punched offset, so it was held in by the wire basket, and really I can’t pull that one out without the handle just coming out by itself I think it was over $40 for the two parts

Every step of the way, some issue like this for every thing.

FWIW - I roasted 8 batches (1kg ea) over two different sessions/days and didn’t have any issues with RT misbehaving. Using RT 4.21.6 with client v1.117.1, proxy v1.42.0 and comms v1.10.56. My f/w is 562 (yes I know it’s old but I’m good with it). I only edit my roasts after I’ve done all my roasting (i.e. I don’t try to edit a previous roast while another one is in progress) for the day.

That is good to know. I was roasting stable (other than P9) on RT4 beta, and some old FW, from before 605.

Had the issue with P9, and the fix was having a cooler room. But they had me upgrade the software and then issues started, so find a work around for one thing and run into another issue. Haha.

Basically I never have an operational bullet in like 2years. (User error, and circumstances being part of it.)

Sorry to hear you had so much trouble. I try to keep things as simple as possible so my use of the roaster is somewhat “manual” and I use the software to monitor the curve and the machine’s vitals during a roast. I hope you find a solution to some of your problems.

As for what looks like defects in your photos above you might want to contact your supplier that you got your roaster and parts from.

I primarily roast manually. I’ve read that some people alter the recipe as they go, but I’ve never had consistent enough results with the Bullet. I’d find something I felt worked, but then something would change. Every bean is different. Idk, maybe if I can work out this software.

I think it is trying to sync online, and I don’t have Wi-Fi, so it is just messing things up. I’ll see if they can wipe my roast world data, and see if that fixes it.

Yeah, I should contact the vendor about those parts, but tech support said they were sending me “chaff filter” or something, and so I waited to see if it was the stainless basket, but it was the fiber one for the cooling tray. I was confused, because I was having issues with airflow not the cooling tray. lol. But yeah, I should follow up about the gasket and the basket. Idk, I may have missed the window waiting on the stuff from tech support. I was trying to save them or someone money rather than doubling up if I didn’t need to.

But yeah, thanks. If I could go back in time, I don’t think I would have gotten a bullet.

If I ever get through to the other side, I’ll end up having a ton of good info, from all the fails. But until then it is just theory as to what might be good

I’ve had this happen a few times now in 15 months. Don’t actually know a common denominator of actions leading up to it’s occurrence other than editing information post roast such as final weight and perhaps bean selection.

1 Like

Yes, that could be part of it, I felt like the roast I edited during roasting did not erase. But I wasn’t paying attention, but yes, occasionally a roast won’t erase written info.

I assumed the issue was caused from adding roast data from the prior year to my “roasts” folder so that I have access. Again, I don’t roast in my home, so I don’t have internet and have to deal with those limitations. But after signing in to roast world (either by taking the computer somewhere else, or a hotspot) is really when the issue happened. However, this was not an issue with older softeware, just RT4 and fw610

Hey all,

We are working to figure out what is causing this issue. But we’ve had no luck recreating it. Would you all be able to provide a more detailed explanation of the workflow you are going through that’s causing this issue.

It would also help if you can provide details about what version of RT you are using and what version of your OS you are on.

Thanks in advance for your help!


From memory (always iffy!)-

I’ve had no issue creating Notes during the early part of the roast (Roast page). However I have found various errors if I try to edit those same notes mid-roast (again, Roast page). Editing post-roast has worked ok but that occurs on the Roast History/Profile Display pages.
f/w 610
Main 4.6.16
Client 1.118.5, Proxy v1.42.2, Comm v1.10.58 (I see I have a new Client to install)


Edit- on a Win11 system

1 Like
  • Mac OS Mojave, Intel processor
  • RT4
  • FW610
  • Bullet V2

The thing I did out of the ordinary was paste old roast files into the “roasts” folder after signing out of roast world.