USB disconnects everytime I press PRS in Roastime 4.3.2

Just reinstalled Windows on my laptop to speed it back up. Did 2 roasts, and on the third roast, Roastime quit charting data or running the recipe. Can not get another roast to start. Everytime I press PRS button in Roastime, USB status changes to disconnected.

I updated firmware to 605, but problem persists.

Software versions are up to date:

Client Latest v1.38.0

Proxy service Latest v1.23.0

Communication service Latest v1.8.2

Bullet R1 v2
s/n 005512

I tried to post log file in response, but it is way too big to fit in a response. It said max characters in 32,000. My log file is 15,012 lines for this roast session.

Same experience is currently happening with me on a Mac—reinstalling RoasTime and power cycling the computer/Bullet did not fix the issue. If I press PRS and wait 10 seconds , the machine will occasionally reconnect by itself, but the timer and temperature values won’t update and appear stuck as well.

Yes. Same here. USB says connected until I send a command (PRS button), then it disconnects. After a few seconds, it reconnects, but no update to time, temperature, or charts, but roaster will switch to PH mode. Press PRS button again, USB disconnects, roaster cycles to Roast, USB reconnects, nothing updates on screen. PRS button seems to disconnect USB, after about 5 seconds, reconnects, and then cycles roaster mode.

Tried rebooting computer and roaster. Tried reinstalling Roastime. Made sure firmware and software are up to date. Tried new USB cable.

Just got home with a new laptop. We’ll see if it is the laptop of the roaster/software.

same results on new laptop

I got 4 orders to fill and a Farmers Market on Saturday.


Can you pls send the log file to [email protected] then he will take a look.
What happens if you press the PRS button on the Bullet instead?

Same thing happening for me today on my MAC. USB errors out when dropping beans into the bullet.

Work around was to close roastime, remove usb, open roastime and reconnect usb while the roast is going (took a few tries usually). Time and Temp values were somehow kept from beginning of roast when I did this as well. Limped through 5 roasts with this method.

1 Like

@here Please send me your software log files by going to Settings->Software. You can email me at [email protected], message me on slack, or send them directly to me via DM here on the community.

Does this happen when you press PRS on the roaster too? Or just from the UI?


Sent log files. I will have to check when i get back home what happens when using the PRS button on the front panel.

On my new laptop, I uninstalled Roastime 4.3.2 and installed 2.5.5 (legacy). I didn’t log in, just used option to open as guest. Everthing appears to work from Roastime 2.5.5. So at least I can rule out hardware issue. I havec narrowed it down to software issue.

Next I installed Roastime 4.3.2 on my new laptop and everything is working.

Now to see if I can repeat it on the old laptop that I have been roasting with for nearly 1.5 years.

For any who may need it, here is the link to the Roastime legacy (v 2.5.5)

1 Like

I received all of your logs file, thanks! It looks like each of you is encountering a different error (from the usb). I have catalogued and commented on the issue and we will prioritize it. Glad to hear that most of you are no longer having the issue.

Thanks again!

1 Like

Worked fine for roast a few minutes ago until the app auto-updated… now I cannot connect and roast the second batch. As a new user, I cannot upload logs. I’d recommend you create a POST route for these or use a third party so users don’t need to handle this.

1 Like

It was insufficient to delete the binary and replace it with the web DMG live as of today. I also needed to remove ~/Library/Application Support/ your folders. Now I am able to roast again.

Cancel that. Dropped. Won’t reconnect. Sadness. :frowning: feature flags!

Another MacBook Air user with problems. My first two roasts went fine with roastime. third roast, roast time kept disconnecting. My MacBook is 6 months old with the latest OS (13.1.1). Frustrating. Aillio, please help. Does it make sense and is it possible to fall back to a previous version of Roastime? Thanks. New user. Michael

1 Like

Hey @michaeljready.0M4Z and everyone else. I have been solely focused on fixing this issue. It has been a bit difficult to solve due to it’s closeness with the OS (LIBUSB_IO_INTERRUPT errors) and being able to recreate it. I think I am pretty close though and I should have a test version to send out to you soon.

Thanks you. :clap: :clap: :clap: :clap: Michael

I don’t know if I just got lucky, but rolling back to 2.5.5 and logging in as guest seemed to “reset” whatever was causing the error. After opening 2.5.5 and it worked OK, I was then able launch 4.3.2 without issues.

I am a macbook user as well. I am having issues with my connection. It will say that I am connected, but disconnect as soon as set my charge temperature. It may come back and connect but it refuses to show any information. I also am unable to perform the “overlay” function of a graph. Any help would be appreciated!

1 Like

@here For anyone still having the issue. I have a new comms built that I hope will solve your issues. If you would like to try it out, let me know and I will add you to the testers group. If it does not help, let’s setup some time to screenshare so I can help debug.

1 Like