USB disconnects everytime I press PRS in Roastime 4.3.2

hi! i have this bug too :frowning:

1 Like


@rokkosteez Just sent you a DM.

@mcaillio Happy to screen share / keep Console open to test the fix. In Seattle, USA.

Great @roastingapps ,

Are you roasting today? Are you on the public slack?


1 Like

Thanks. I’d like to be one of the testers but I won’t be able to roast for a couple weeks. I’ll monitor the thread and see how it goes with others. Thank you for your help! Michael

Im having the same issue, says connect but then disconnects right after pressing PRS, on a MacBook, Roast Time 4.3.2

1 Like

Added you to the testers cohort. You should get an update when you startup. Let me know.


Hellloooo everyone!

We appear to be having the same issue with our bullet, pretty well precisely as described… I am using the latest windows and software versions!

please help!

Will try the legacy install.

Thank you!

Good luck. My roaster is still running agter going thru the process of reverting back to legacy to get things working.

1 Like

Same issue with me on the mac. Went back to RT2.5.5 and seems to be fixed. Looking forward to a solution for RT4

After going back to 2.5.5 and it working, i was able to reinstall the current version and everything has continued to work.

Hey all, still waiting for someone on mac with the issue to try out the new version. I have had someone with windows that had a similar issue that is now fixed. Please let me know if you can test this.


I’m happy to test on the mac

Hey @pranskunas.luke0b94,

Thanks for being willing to help test this. I added you to our beta testers list and so you should be able to start RT and get the latest comms. You should get an update for the Communication Service v1.10.9.


Moving my previous thread here since it seems to be the same issue:

I'm in a doom loop. Running on Windows. Reinstalled latest software. Updated driver to latest. Hard restart of roaster and PC. Every time I get started it disconnects as soon as I click preheat in Roastime. Then it immediately "reconnects" and brings me back to the temp select for preheating. Often, my roaster will begin the preheating process but the software won't recognize it. I've tried everything multiple times and would love some help. Super bummed to be spending time with software issues instead of roasting coffee.

I’ve since uninstalled 4.3.2 and installed 2.5.5. That version recognized my roaster and seemed to work. I went back to 4.3.2 but it still doesn’t work so the fix from @shane1 didn’t work for me.

Any help at all would be very welcome. I had assumed that a product on the market for 5 years wouldn’t have these sorts of issues.

1 Like

Hey @talentpharm.IIsj , also added you to the testing group. Let me know if this fixes your issue.

@mcaillio I just completed 2 successful roasts after downloading your test updates and restarting roaster and PC. Thank you!

Seems to work great on Mac OS, connects and cycles correctly through roast phases using both the controls on the roaster and the controls within RT. Thanks!

Thanks @here for the feedback. We will be releasing this in a new main version today. See RoasTime v4.6.6

1 Like