Error Code: 256

I’ve started getting the error EC 256 during my preheat cycle recently on my R1V2. It will only flash on the display briefly and then disappears. The display also changes from PH to PH6. I’ve only put a dozen or so roasts through my machine and I’m running FW 531. If I’m reading the error codes correctly, this relates to low input voltage. I’ve have a digital meter that continuously displays line voltage and amp draw. The voltage is always between 119 and 124 VAC.
Since everything else seems to work ok, should I just ignore this or might this be an early warning sign of an induction board failure I’ve read about?

Please try updating to the latest beta version of the firmware and let us know if it continues.

Thanks Jacob. I just installed 540 and ran through a preheat cycle with no error. I didn’t have enough time to do a roast but the error always happened during preheat. Fingers crossed.
Does the fan have to be recalibrated after a FW update or is that a one time event?

Mine just started giving the error today. Immediately after plugging in i get the error and it will not even begin the roast. Firmware has been updated for a month or so.

I appears that some bullets have caught the pre-heating flu!! After no problems for a few months, today I got the dreaded 256 error on pre-heating. But when I pushed the main button, it said “charge” and I completed the roast. The bullet was at my chosen 185C temperature anyway. Interestingly, I was using Blake’s anti-Rao (my term) recipe; a 21 minute roast on Kona beans. The recipe didn’t execute the 1 minute marker, or the 200C trigger. But all other triggers worked.

After this was all over, I upgraded the firmware to the latest beta. Not easy to find where to do this with Mac OS X!!

Now, we’ll see if the firmware fixes the issue. I have my doubts.

1 Like

I contacted sweet marias letting them know of my Error 256 and they responded last night. They will be sending me a new board when they open tomorrow. Very thankful for sweet marias support on this issue and aillios willingness to admit the issue. Honestly, even if it does kind of suck, it makes it not that much of a big deal when the company is freely admitting the problem and are committed to fixing it.

Interesting. Blake, I also contacted SM via email and they told be the tech was out “until 2020” and suggested I contact Aillio directly. I upgraded my firmware to the most recent beta and have had no problems.

Did you contact the bullet technical support with SM?

[email protected]

Julio is out. I got an auto message from him stating he was off through the 3rd i think. Ryan got back with me on the 31st though. He told me he would get it shipped out Thursday the 2nd.

My firmware was updated quite a while back. Im not even getting the error during preheat. I get it immediately after plugging in and cant go any further. I think i may have gotten this error one other time while preheating for my first seasoning batch when i first got it in november. It was some ErC but it being my first roast it really took me by surprise and i missed the number. I didnt get it again until now and i guess the board is totally out now.

Following up, 2 or 3 days later: did my first roast after the firmware update. Roast completed without a hitch, so I’m somewhat relieved. But still concerned…

I’ve also done 2 roasts after firmware upgrade and no problems. Like Matilsky I’m also concerned about 2 things.
1- Did the firmware upgrade just ignore the condition that was triggering the error and not throw a code (ie. - don’t worry about it)?
2- Will my induction board fail from this issue days after my warranty runs out?
I guess time will tell. fingers crossed in the mean time.

Got my new PCB in from sweet marias. powered up with no problems now. Will try to roast in the next day or 2.

The ErC 256 can happen with old firmware when the induction is stopped - goes to P0. The voltage measurement at that transition would be wrong. This has nothing to do with an actual voltage problem, so we have changed the firmware to be less sensitive during the transition period (we are talking milliseconds). The board will still trip on an actual under / over voltage.

1 Like

That would explain why it would preferentially happen during preheating! It’s the only time the power would go to P0. Now I’m even more relieved! Thanks for the detailed explanation, Jacob.

1 Like


I have had my Bullet since February of 2021 and used it for a little over a year with no issues at all. However I have been busy the last few months and haven’t been able to use it until today (about 4 months of not using it).

Today I tried preheating it and the red LED on the side of the roaster was blinking, then I was given the error code 256.

So I installed the latest stable firmware and got the same thing. Then I decided to try the newest beta and it preheated the roaster to 240C and made it to the charge promp.

A few minutes after I charged the beans, the roaster stopped heating up again and prompted me with error code 256 again, and the light on the side was also blinking again (a total of 9 blinks).

Wondering if anyone else has experienced this and might no a fix?


According to this thread you might want to contact Aillio support.

Oof I was hoping that wasn’t the case. I bought the roaster through Sweet Maria’s, so I just sent them a message

Can you monitor the voltage in RoasTime? Click on the (i) icon top right on the roasting screen.
The error suggest that your voltage is too low.
You can also try another outlet to see if this solves the issue.

Wow. I got the same error last night too but I wasn’t able to update the firmware (I was on the latest stable). The voltage just shows 0. I emailed support and am waiting for the next steps.

So I tried again and was able to complete a roast. And I finally made the switch from Roastime 2 to Roastime 3 to see if I was having a power issue, and voltage readings were in the low 100’s, way too low.

I think the problem might have been the new extension cable I was using. I had never paid much attention to what gauge the cords were before, but the new one is 16AWG and the one I used before is 14AWG. And after doing some research it seems the 16AWG cord might be dropping the voltage.

Im hoping this was the problem and I will report back the next time I roast with the 14AWG cord to see if that resolved the issue.