Roastime crashing

I am roasting on Debian Testing with latest RoasTime 4, no problems so far. My last successful roast was on May 9th.

When I wanted to roast yesterday, however, RoasTime crashed with a SEGFAULT in the Chromium process. I am not 100% sure if it was right away or after the usual update-restart. Anyway, it seems to have something to do with window size. When I reduce window size to

{"width":1500,"height":1048,"x":10,"y":32,"isMaximized":false,"isFullScreen":false,"displayBounds":{"x":0,"y":0,"width":1920,"height":1080}}

then the app starts. The weird thing is that I had it running with a wider window as well, but when I tried to find the breaking window size I had to go down further than before. That is at some point it worked with width 1600, but now it doesn’t.
Before I had the window maximized, but when I do that now the app crashes right away.

Any ideas what’s going on here?

On windows there is a file called “window-state.json” which saves the last state of the window (not sure about Linux). Perhaps this is corrupted or set out of bounds? You could try deleting / changing it. On windows it is found in: …\AppData\Roaming\RoasTime

Actually, I edited that file in order to try out different window sizes. You can see the full content of a working file quoted in my original message.

@sturmdcwm Which specific version are you running on the main process? Is it 4.6.36? I did a large upgrade of Electron in the latest version, so I wonder if there was a breaking change with this.

Does this only happen on startup? I assume you can make the window bigger after the fact?

Yes, I run 4.6.36. I can resize the window at will while the app is running, but then it segfaults on restart. However, maximizing the windows crashes the app right away.

FYI - I found this is a bug in electron itself: [Bug]: SIGSEGV crash when maximizing window · Issue #41839 · electron/electron · GitHub

Looks like it was fixed very recently, so I will test, update and release a new version for Linux.