RT 3.2.5 Screen Freeze

Bullet V1.5 F/W 558

On October 16 my Bullet upgraded to 3.2.5.
Issue #1
On my 2nd roast of a Back to Back session, the RT graph froze about halfway through the roast. I was able to finish it using the control panel.

Today, 10/26, I roasted 2 batches BTB and during both of the Pre Heat periods the same RT graph freeze occurred. Each time I restarted RT while the Bullet continued pre-heating, and the PH time-elapsed picked up where it should be, but of course the graph restarted. Each roast then completed with no problem.

I upgraded the Firmware to Beta 602 after these roasts, but did not have time to roast again as a test.

Issue #2
I also noticed that the Info button at the top right had disappeared. I was able to hover the mouse over where it should be, to the right of the pencil, and the pointing finger appeared…I clicked the blank space and the Info box appeared. My screen background color is white. I did look at this quickly after upgrading the Firmware to Beta 602 and the Info Button is still in ghost mode. :ghost:

Any thoughts? Thanks.

1 Like

Issue #1
Did it freeze during roasting with version 3.2.5?
We have a new release coming out soon with more improvements to the USB stuff.

Issue #2 Make sure that the Theme “Secondary” and “Secondary Text and Icons” are not both set to the same color.
Does it work with the Aillio Light Theme?

Thanks for the incredibly fast response.

#1. Yes, the freezes started after the 3.2.5 download.

#2. I changed the Theme to Aillio Light and the Info button is back! I like the Light theme and will try it when I next roast. BTW, I had not changed any of the Theme settings in a long time, so wondering if the new 325 defaulted both of the Primary and Secondary Text to the white color.

Again, thanks for keeping RT growing in features and fun to use.


1 Like

I sent you the new version via slack.

Thanks! Roasting with it now.

I believe the issue is that the Primary region isn’t defined on the Roast page. That area needs to be treated as part of Chart which would give it a contrasting color.


Also freezing for me on 3.2.5.
Did 2 roasts back to back, and on the 3rd it started freezing.
When it froze, I tried closing down roastime and relaunching, and after 10-30 seconds it froze again.

I have sent you a personal message.

You sent it to joakiml, not me, right?

I have the same issues as you. On another forum others have had same issues. There was a guy claiming he was an IT engineer. He said to unplug the PC and only use on battery power. He claims that charging will mess with information via USB. I have not roasted trying this yet. FYI. Worth a try tho.

I was using a desktop PC, so unplugging will probably not help. :grin:

Right, just sent it to Joakim as you have it from Slack already.

Anyone else that may be encountering this issue - please try using v3.3.0 here by following the instructions here: V3.3.0 Soft Release

1 Like

I’m having the same issue with RT freezing on occasions after Bullet preheating, before charge. I’m on version 3.3.2, on a laptop running Windows 10. I haven’t had this issue before upgrading.
It goes away on RT close/reopen but it’s messing up the roast data.

1 Like

I thought I had this figured out…thought it was happening when my PC would go into screen sleep mode during PH…but just now, while preheating, it happened while I was still using the PC, using RT to look at Roast History…when I returned to the Roast in progress, it was frozen around 10 minutes into PH .
Win10, RT 3.3.2, 602

I had this happen the same way as you describe. However, I couldn’t just restart RoasTime. If I tried restarting RoasTime, the screen would flash like it was going to load but then nothing would happen. Now when this happens, I end up rebooting my laptop.

I’ve had this happen after charging also and lost the beans in the drum.

I’ve had this happen too. I read not to have pc plugged in when using Roastime, battery only. I thought that worked till the other day it froze, wouldn’t open roastime after I exited/X’d out. Had to restart pc and 45 seconds into it, it froze again. Had to finish the roast manually. Which turned out well.

I noticed RT won’t restart straight away after exiting, I have to wait for a few seconds for it to finish exiting before it will start again. Or I keep trying to open it a few times and eventually it works. It’s faster than a reboot :).

hi I had the issue today of RT freezing telemetry, all other functionality still worked. What i noticed, when i quit RT, it wouldnt restart as just quit straight away - same issue despite multiple restarts. I reinstalled and then had to power cycle roaster as PC reset still had issue occur. Fixed for now - highly frustrating as nearly lost 400g beans. Im using a PC so cannot use laptop. Mains is on same power strip to avoid ground loops.

One thing i noticed with older roaster (Hottop), switching any heavy load mains gear caused similar issue - mains spikes can be one of the factors that seems to affect USB telemetry

RT is cleaning up some resources and synching some data when you quit, so you have to wait until that process is done until you can restart. If you are not connected to the internet it might take a while for it to timeout. What firmware / RT version are you on?